WebHook Not Working As Expected

I have created a User managed OAuth app with Intent to publish = No. The API’s I use all seem to work OK with the end point url I am using.

Now I wanted to add a webhook feature to this App. So I added the Chat Message feature with an end point url but It doesn’t work as expected. I never receive a webhook notification when a new chat message is add to my channel.

Am I doing this correct since all I want to do is receive this chat message via the webhook?

Also since my App is set to Intent to publish: No is that causing no webhooks to be generated. The Webhook Logs show no activity.

Thanks for all your help

Hey @moneil,

Can you share screenshots of the issue and steps to reproduce please? :slight_smile:


Well I went ahead and created a Webhook Only app to see if I would get better results. But I didn’t receive any webhooks from that one either. Here are the screen shot I took to develop this Webhook Only App:

I then ran some test by started a chat and starting/stopping a voice recording. I then checked the Call Logs/Webhook to see if anything was send and nothing was there under WebHookOne.

Can you tell me at least if I am creating this correctly and haven’t missed something.


I did get the WebHook Only App working OK… now I want to get the OAuth App working.

For the OAuth APP the scopes are working OK (using the API scopes for listing channels and messages) but I’m somewhat confused as to how to get the Features (WebHook) part of this OAUTH APP working?

Currently the OAUTH APP is “Ready to install” if I run the Install Link the redirect url opens and I’m able to use and test the various SCOPES working OK, but how do I test the FEATURES (Webhooks) of this APP? The Features I added for this APP are Meeting Start/Meeting End but I don’t seem to get any webhook active when I start and stop a meeting.

Thanks for your help.

Hey @moneil,

Happy to hear you got the webhook app working. What was the issue?

Did you add the same webhook endpoint url? Also make sure the user who installed the app is the one triggering the webhooks (for user level OAuth apps.)


The issue I had for the WebHook Only was a coding error and I corrected. that and it worked OK.

But I still can’t get the OAUTH App working for Webhooks, the end point is the same as what I used for the WebHook Only. As far as who triggers the webhook Yes I am the only user.

What happens when you have 2 or more OAUTH App installed for a user and both have the webhooks enabled for the same Feature such as meeting start/end meeting?

1 Like

Hey @moneil,

Happy to hear you got webhooks working for the webhook only app.

For the OAuth app, make sure you have installed your app and it should work.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.