Webinar enabled not working on User Settings

As part of an implementation around the Meeting SDK, we have been asked that the account holder we create Webinars with be created through custCreate and assigned a Webinar license. I am trying to accomplish that task, but I am failing to be able to enable the Webinar for the account in question.

My current understanding is that this is done through the UserSettings end point.

*Note, we do in fact have available webinar licenses on our account. I could manually assign the Webinar to the account via the web UI after logging in as the account holder, confirming that i do in fact have these licenses (9 of them to be exact).


  1. Call /user/{id}/settings GET - Retrieves User Settings.
  2. Change value of Feature.Webinar to true. Setting MaxSeats to 500.
  3. PATCH back to /user{id}/settings using the same object with the changed value.
  4. Receive OK response.

Expected Result:
I log into the Web UI and see that the Account now has Webinar on it.

What I see:
I log into the Web UI and see that the Account does not have Webinar on it, indicating that the Settings PATCH silently failed to update.

What I have Tried in Addition:
I tried settings a benign value via the PATCH (require password on meetings) from false to true. This ALSO fails to change the settings after the PATCH.

Any idea what I am missing or should try?

Hi @development_1
Thanks for reaching out to the Zoom Developer Forum, I am happy to help here!
I have tried to replicate this issue on my end and I am able to assign webinar feature to the user.
Could you please share with me the request body that you send when you create the user and also the request body that you send when you patch the settings.