WebSDK SSO Authentication with External Service

I’m having trouble getting SSO to work on the Web SDK with an external SAML connection, it works fine for the Zoom app and web client.

The key error is that the ACS URL in the Metadata XML File seems to be different for the SDK (I think)?

I need for users to either be able to authenticate with SAML or skip it entirely/do it programmatically for WebSDK users (preferred, since these users are on the exact site we’re using to power SAML in the app/web client).

Which version?

Maybe more clear questions:

Is there a way to bypass authentication profiles via WebSDK?

Do external SSO’s require something special to work with the SDK? The ACS URL seems different.

Hey @classrooms ,

Can you share a screenshot of the error and steps to reproduce? :slight_smile:

Not unless you turn off the authentication profiles for the meeting.


Hi @tommy,

There isn’t an error screen, but basically when you click Sign in With SSO on the SDK it takes you to a new window for the IP, but it doesn’t pass a SAML request through. Using SAML Request, in the App/Web Client, it shows a SAML request along with _x_zm_rtaid and _x_zm_rhtaid parameters, but on the SSO SDK Button it only sends the Identity Provider _x_zm_rtaid and _x_zm_rhtaid parameters but no SAML request, so it never gets authorized.

I can send the two different SAML traces (for web client/app vs SDK) by email/upload if that helps.

Hey @classrooms ,

Gotcha! I have let our engineering team know about this issue. (CS-2947) I will get back to you with an update as soon as I can ! :slight_smile:


1 Like


Would something like this show up in the changelog? Just checking out the 2/1 release notes and wasn’t sure if it would even show up if it was fixed.


Hey @classrooms ,

Yes, however, I will also notify you here. :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.