New SSO login usage in Windows SDK

Description
Wondering how to use the SSO Login in the Window Desktop Demo app

Which Desktop Meeting SDK version?
v5.7.1.644

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Run sdk_demo_v2
  2. Set Domain "https://zoom.us
  3. Authorize the sdk
  4. Click SSO Login tab

How is this page used to login to the SDK?

I tried putting my vanity URL prefix in and clicked generate web url. This launches the url in the default browser which after signing in asks to launch the desktop app which appeared to do nothing.

I then put ‘https://’ as the SSO login Web URI protocol and clicked login. Then the second screenshot window appears. At that point it doesn’t appear that I am signed into the demo app.

Screenshots
image
image

Device (please complete the following information):

  • Device: Dell Latitude 5590
  • OS: Windows 10 Enterprise 21H2 (19044.1263)

Additional context
Add any other context about the problem here.

Hey @damien2,

Thanks for using the dev forum!

Have you configured your IDP with Zoom? Quick start guide for SSO – Zoom Help Center

Thanks!
Michael

Yes, we have configured our IDP with Zoom and are able to use the Zoom desktop client with SSO.

Hey @damien2,

I see. Can you reproduce the issue once more and then send your SDK logs via email to me at developersupport@zoom.us? Please mention my name and a link to this post.

Thanks!
Michael

Sent in the log file

Hey @damien2,

Thanks! I see them. One more question, after going through the SSO flow and providing the information above, are you able to start a meeting?

Thanks!
Michael

No, I am not able to join a meeting. If I enter a meeting Id and click join. That window disappears and the main window still shows ‘waiting sso login…’

Hey @damien2,

Can you reproduce the issue once more and then send over the SDK logs from that instance? They can be found at %appData%/roaming/ZoomSDK. Please send them to me at developersupport@zoom.us and mention my name and a link to this post.

Thanks!
Michael

Hey @damien2,

Can you try this:

  1. set domain, like: https://zoom.us
  2. call GenerateSSOLoginWebURL(your prefix_of_vanity_url)
  3. Open the url obtained in step 2 in the browser. The browser will complete the login process. Press F12 to view the source code and find the url starting with “zoommtg” in the source code. Call LoginWithSSOLoginWebUriProtocol with the url as parameter.

Thanks!
Michael

Thanks Michael, That was exactly the info needed. It would be good to add this info to the documentation.

*** Note *** I found that after trying this in the C++ demo app I was getting LOGINSTATUS.LOGIN_FAILED with a LOGINFAILREASON.LoginFail_OtherIssue in our application on the same system. I of had to delete the %APPDATA%/ZoomSDK folder to get it to work in our application as I was using the same SDK auth info in both.

Hey @damien2,

Gotcha, we will work to get this added to the docs.

Thanks!
Michael