When joining first meeting video does not show

Description
When joining a meeting for the first time the video does not show. It is only after the user touches the video share twice (once to turn off once to turn back on) video can be viewed on device. This work around seems to also work when touching mute twice.

Which version?
4.1.30420.0817 is what I am working with but I have tried all versions 4.1.30420.0817 and above. I did notice in the most recent version I can see video from the device in the bottom left without any issues on first call but not the other participant.

Smartphone (please complete the following information):
Iphone7
12.3.1

Hi,

We have received your request and will be responding to you shortly.

Thanks

Hi j.phillips,
Thanks for using Zoom SDK. Glad you have tried the most recent version, we always encourage the user to use our latest version for usability and stability. And pardon the inconvenience caused by the issue.

Could you provide the screenshot and the SDK log so that we can try to find the root cause?

Thanks!

I don’t have logs right now but I have narrowed this issue down to permissions. If I request and grant permissions to camera and mic before I try to connect to a meeting I do not see this issue. It would be nice to be able to call a method in the sdk to request permissions directly instead of waiting for the first meeting.

Hi,
Thanks for the reply. Our SDK requires certain features that require permissions, please specify the following permission in your info.plist file:

info.plist
<key>NSBluetoothPeripheralUsageDescription</key>
	
<string>We will use your Bluetooth to access your Bluetooth headphones.</string>
	
<key>NSCameraUsageDescription</key>
	
<string>For people to see you during meetings, we need access to your camera.</string>
	
<key>NSMicrophoneUsageDescription</key>
	
<string>For people to hear you during meetings, we need access to your microphone.</string>
	
<key>NSPhotoLibraryUsageDescription</key>
	
<string>For people to share, we need access to your photos</string>

The full detail is in our documentation: https://marketplace.zoom.us/docs/sdk/native-sdks/iOS/getting-started/integration#4-required-permissions

Regarding the permission checking and request to ask for granting permission, the following links and guidance would be helpful:

Once the user denied the permission at the first time, then it is hard to request again. And it is also not possible to request for permission before the SDK function has been triggered. You could try to request the permission(e.g. camera) in your own app that integrates our SDK so that our SDK can get the permission to use camera as well.

Hope this helps. Thanks!

Yeah I have all that set up already, the app asks for permissions my only problem seems to be that the video does not transmit to the device in the initial meeting. The user has not denied any of these permissions at this point, this is the first time they are being displayed. Once the user has granted permissions there is no issue so I have no issues going forward.