Windows SDK Demo FAIL in VS2019 (& 17)

Description
Windows SDK Demo fails build in VS2019.

What am I missing?

Which version?
v5.0.24433.0616
sdk_demo_v2_2017

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Download and unzip demo SDK master (also attempted Git clone)
  2. Open sdk_demo_v2_2017.sln solution with VS2019
  3. Confirm retarget project window (see screenshot)
  4. Set Local Windows Debugger options to ‘Release’ and ‘x86’
  5. Fail (see below build output in screenshot)
  6. Repeat steps 1-3 above, but also make changes 1-4 from …/getting-started/install-sdk
  7. Fail again (same)

Screenshots

Additional context
Also tried to build in VS2017 with same zoomHmacSHA256.cpp source error outcome.

Hi @treyc,

Thanks for the post. We have removed the following 4 files in the demo app since they are not being used:

  • zoomHmacSHA256.h
  • zoomHmacSHA256.cpp
  • HttpRequestHelper.h
  • HttpRequestHelper.cpp

However, somehow the links to the above 4 files still exist in sdk_demo_v2_2015.sln and sdk_demo_v2_2017.sln. Please try to remove the reference to the above 4 files and then it should work.

Thanks!

Having the same problem. Can’t find an references to those files. How do we find them?

Hi @msides,

We have updated the Windows SDK demo app for this issue. Please download the latest version of Windows SDK and try again: https://github.com/zoom/zoom-sdk-windows

Thanks!

Thanks, It compiles and runs now.

One further question if I may:

When it runs, I enter our domain, then get this prompt: What am I supposed to enter here? I followed the instructions and I started an App and got as toke, but it doesn’t work. Thanks so much.

image001.png

msides, this is the issue I was actually having. Glad to see I’m not going crazy. Reverting to the previous official version (two commits ago in git), there are two boxes, one for token and the other for secret (sdk or jwt).

Now that I’ve done a bit more testing, I’ll elaborate:

I have built the demo application using vs 2015 and 2017. Both successfully compile the code and produce a .exe file. When run, both will produce the panel pictured in msides last reply after entering the domain. No combination of keys and tokens (sdk or jwt; key, secret, or token) can get me past that panel.

This is with the latest version (commit made 4 days ago).

When I revert the last two commits, I instead get this:
image
This works with my sdk credentials, but checking the “Auth with JWT token” box doesn’t allow me to log on, though the boxes themselves change.

Hi @msides,

Thanks for the reply. The JWT token here is a JWT token that is generated by SDK key/secret, not the JWT token that is generated directly from the Marketplace. Once you have the SDK key/secret, you may follow the instruction here to generate the JWT token: https://github.com/zoom/zoom-sdk-windows/blob/master/CHANGELOG.md#new-sdk-initialization-method-using-jwt-token.

Hope this helps. Thanks!

Hi @nick_ortega,

Thanks for the reply. We are trying to encourage people to use the JWT token that is generated from SDK key/secret instead of using the key/secret directly. We are working on enhancing the documentation to reflect this so it might be a little bit confusing right now. Please see my answer above for the instruction.

Thanks!

Carson,

Thanks for the reply. From the GitHub changelog, I was able to generate a jwt token from the sdk key and secret, but I still get the “auth sdk failed” error panel. I’m not sure if I’m formatting the timestamps and “tokenExp” correctly. Are “exp” and “tokenExp” the same? Is there a specific format? I would guess ISO 8601 for the timestamps, but I still don’t know that “tokenExp” should be in that case.

Thanks,
Nick

@Carson_Chen, thanks again for the help so far. I am generating jwt tokens from the sdk key/secret, but I still get errors. Now, the error panel that shows is seen below:
image
I’ve looked through the documentation, and I can’t find error code 10124. Any ideas on this one?

Hi @nick_ortega,

Thanks for the reply. The error code 10124 means “Unable to verify the token”. Could you provide an example of the payload of your JWT token?

Thanks!

Carson, thanks so much for helping me with this. On another thread, I discovered the problem with my payload. Somewhere along the line, I switched “appKey” to just “key”. I now have it working.

I am still getting the 10124 error. my payload is
Hi @Carson_Chen, @nick_ortega
{
“key”: “--------------------hidden-----------------------”,
“iat”: 1595755181560,
“exp”: 1595757009404,
“tokenExp”: 1595757009404
}

@Carson_Chen I found the solution in some other post. Its working now-

Hi @anuragnagarkota,

Thanks for the reply and glad to hear that the problem has been resolved.

Thanks!

Hi,

I’d like to ask for help here as well. I’m trying to run the SDK demo on my own laptop and I’ve got it running without issue. But when I try to add the JWT token I generated, it returns an error saying “auth sdk failed”

This is the payload I’m using:

Header
{
“alg”: “HS256”,
“typ”: “JWT”
}

Payload
{
“appKey”: “…”,
“iat”: 1516239022,
“exp”: 1516239022,
“tokenExp”: 1516239022
}

Verify Signature
HMACSHA256(
base64UrlEncode(header) + “.” +
base64UrlEncode(payload),

… …

)

Could someone help me find out how to make this work?

Thanks!

Hi @danielle.ureta,

Thanks for the reply. Based on your JWT payload, it seems like the iat, exp, and tokenExp are the same; The iat is the token issue time, and the exp will be the token expiration time so it needs to be larger than iat, and the tokenExp should be a timestamp that is at least 30 minutes from the iat. You may find more info here: https://github.com/zoom/zoom-sdk-windows/blob/master/CHANGELOG.md#new-sdk-initialization-method-using-jwt-token

Please have a try. Thanks!

Hello,

I’m using the advised iat, exp and tokenExp times but keep getting error 10124. I should note that I’m manually setting these times at jwt. io .
Is there a way to add this to the node js api ?

Thanks in advance

Hi @username234234234,

Thanks for the reply. Are you using SDK key/secret to generate the JWT token? Could you provide another sample of the JWT payload? In the last sample of the JWT payload, the iat, exp and tokenExp are the same, which causing the error.

Thanks!