Windows SDK Demo FAIL in VS2019 (& 17)

Hi @Carson_Chen,

Having a similar error. I get error code 10124 when I generate my jwt from jwt.io.
Here is my header, payload, and verify signature:
{
“alg”: “HS256”,
“typ”: “JWT”
}

{
“appKey”: “”,
“iat”: 1597693709,
“exp”: 1598693709,
“tokenExp”: 1597793709
}

HMACSHA256(
base64UrlEncode(header) + “.” +
base64UrlEncode(payload),

)

the appKey I fill with my SDK key from my SDK credentials on the zoom marketplace. The SDK Secret I have pasted in with and without quotes. iat < tokenExp < exp. I have my domain still set to https://zoom.us

Any advice? Thanks in advance!

Hi @benv28,

Thanks for using Zoom SDK. Please try to limit the exp to be less than 2 days away from iat. Please have a try. Thanks!

Hey am also getting 10124 error code
{
“alg”: “HS256”,
“typ”: “JWT”

}
{
“appKey”: “keyyyyyyy”,
“iat”: 1597991611000,
“exp”: 1598024011000,
“tokenExp”: 1598027611000

}
HMACSHA256(
base64UrlEncode(header) + “.” +
base64UrlEncode(payload),

)

what can be done to resolve

Hi @pavanschoovideos,

Thanks for the reply.

The unit of the timestamp should be in seconds, please try to convert the timestamp.

Hope this helps. Thanks!

{
“appKey”: “sdk key”,
“iat”: 1598076000,
“exp”: 1598162400,
“tokenExp”: 1598169600

}

getting same error.
will this be the error of time stamp what kind of timestamp should i use can you give a date format for generating timestamp

i have resolved the error it was due to the sdk that i was using when i changed the sdk it works

I too, like everyone else here, am having problems getting the JWT to work in the sample app.

{
“key”: “my app key here”,
“iat”: 1598404372,
“exp”: 1598490772,
“tokenExp”: 1598490773
}

just give the dreaded 10124 return. Authenticating using my app key and secret works fine. I have tried setting “tokenExp” to values before, equal to and after “exp”, to no effect.

JWT.IO reports the “iat” and “exp” values as correct dates.

I’m really struggling to make this work. Failing at the first hurdle in the sample app makes it very difficult to work with this SDK.

Hi Carson,

Is this the same version (v_2) that your site points to? The readme in v_2 that your site points to refers to the latest project as ‘~new’ instead of ‘~v_2’. The reason I ask is that I am dealing with the same errors this conversation thread addresses, using the v_2 from your site.

Could you provide a URL here for each, please … (for my sanity)
URL of zoom-sdk-windows-master latest
URL of zoom-c-sharp-wrapper-master latest

Is v_2 the same as ‘new’? I have gotten errors with v_2 referencing ~DOT_NET_~WRAPPER vs ~C_SHARP~_WRAPPER so I cant be sure if I’m using a correct build.

Thanks Carson!

OK I have built both projects, here’s what my issue was in case anyone hits the situation where no matter how they follow the instructions, and include everything in every conceiveable path, it can still not find linked symbols, and what the issue was. Hint C++/C# newbie pilot error.

When I first tried to build the combined solution, and chose (don’t do this) upgrade the tools reference, it caused an update force on windows 10. Then an install of VS 2015, then 17 etc. to handle incremental tools issues,and during all this some reference to Windows dlls version conflict (I’m assuming) caused the underlying issue. Reistallation of VS 2019 and a clean setup on the _V2 project enabled building both the C++ sdk project and the combined demo solution.

Thanks for all your help guys

Thanks again for developing the wrapper!

I just found the one-way upgrade issue warning in the SDK instructions; might be helpful to add this to the C# wrapper instructions if it saves other time/support tickets.

Hi @gshirreffs,

Thanks for the post and pardon the late response. Please try to make the “exp” larger than the “tokenExp”. Everything else looks good. Please have a try.

Thanks!

Hi @Jonaskinny,

Thanks for the posts and pardon the late response. Glad to hear that you have found the solution. I will forward your feedback to the doc team to enhance the instructions. Let me know if any other questions.

Thanks!

Hi

I am still getting the same error code 10124, though I tried everything listed here.
Could anyone find a solution?

Here’s my payload for generating jwt token
{
key: ‘91NNRvxql4exgNqU6BmMc6WQkJ05u1jDrzUUCopy’,
iat: 1601955894,
exp: 1602128694,
tokenExp: 1602215094
}

I am really exhausted to make it running in my local environment.

Thank you and I am looking forward to getting a solution.

Hi


I tried this already but it’s still not working in my side.

I tried electron-sdk sample and windoes-sdk sample
But failed.

Could you please help me how to make it working?

Hi @simon.andrei879,

Thanks for the reply and sorry to hear that it is still not working for you. Here is a python snippet that could help you to generate the JWT token:

iat = long(int(time.time()))
exp = long((datetime.datetime.today() + datetime.timedelta(days=2)).strftime("%s"))
tokenExp = long((datetime.datetime.today() + datetime.timedelta(hours=1)).strftime("%s"))

    payload = {
        'appKey': key,
        'iat': iat,
        'exp': exp,
        'tokenExp': tokenExp
    }
    encoded = jwt.encode(payload, secret, algorithm='HS256')

Please have a try. Thanks!

I am having the exact same problem as everyone. I entered all the required sections carefully, but yet I keep getting the 10124 return on the sample app. What can I do to make it work? here’s what i entered into the JWT.io: [version v5.2.41727.0928]
{
“alg”: “HS256”,
“typ”: “JWT”
}

{
“appKey”: “…”,

  "iat": 1602913345, 
     "exp": 1603000762, 
     "tokenExp": 1602925162 

}

Hi @mitchwongg,

Thanks for using Zoom SDK. Could you have a try with the code snippet I posted above and see if that helps? You may find more details here: https://github.com/zoom/zoom-sdk-windows#initializing-sdk-with-jwt-token

Hope this helps. Thanks!