/workspaces/assets - New API not functioning

Format Your New Topic as Follows:

API Endpoint(s) and/or Zoom API Event(s)
Zoom Workspace Assets API:

Link the API endpoint(s) and/orZoom API Event(s) you’re working with to help give context.


I’ve come across the following post in the changelog, which is something that I’ve been asking my CSM for for a long time, so keen to try it out!

Unfortunately, I can’t get a simple GET call to work.
There’s no variable fields listed in the GET /v2/workspaces/assets call, so I don’t need to provide a workspaceID, or an assetId - however the API is returning an error:

Invoke-RestMethod : {“code”:8204,“message”:“Workspace not found.”}

Invoke-RestMethod : {“code”:8204,“message”:“Workspace not found.”}


Sorry to tag you both - are you able to have a look at this please? I’m struggling with this one still, and there’s no documentation on the API Reference pages for these endpoints

Tried it again this morning, looks to now be functioning!

Not sure what changed, the GET call which was failing is now returning assets.
Can’t see any changes in release notes, or changelog, perhaps it was a backend server upgrade…

Un-marking this as solved - there’s nothing on the changelog, or anything in the API Documentation to advise how the schema for the PATCH/POST calls should be formulated.

@tommy @gianni.zoom @rehema.zoom @jayne.lacey
Is anyone able to advise when the supporting documentation will be released, please?

    • POST /v2/workspaces/assets

This appears to simply need a json schema with the field name: name

  • PATCH /v2/workspaces/assets/{assetId}

This also appears to simply need a json schema with the field name: name

I’ll mark this as solved again, but hopefully we can get documentation added/updated soon to help others.
I’ll link it on this thread if I see it

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Hi @philip.ross ,

I was out of office, but here is what I see:

(the request body schema is supplied)