Zoom API Unexpected Results

My account # is Account No. REDACTED

Personal Meeting ID [REDACTED]

A full description can be found under this ticket #:
Your request (#10082953) has been updated. Reply to this email or follow the link above.
Assigned to: Biboy Bidayan

I have an application that uses the Zoom API for virtual sessions. This application has been work well until last week when I started to get unexpected errors.

When I start a Zoom session from my application using the Zoom API the session starts but I get an error message telling me the Camera is not recognized and my browser doesn’t support audio. This happened on at least two different Macs and on iPad using the latest version of Chrome.

This all worked prior to last week. Here is a screenshot of the message.

Attached is a screenshot of the error I am getting in the application Ivy Bound. The application is written in PHP Laravel.

Here is the OAuth ID - REDACTED

And the JWT Client ID: REDACTED

And the JWT Token: REDACTED

Screenshot link:

There is a second application named Doceo77 it also uses the Zoom API. It display video but no audio. It is also written in PHO Laravel

Here is the OAuth ID - REDACTED

And the JWT Client ID: REDACTED

And the JWT Token: REDACTED

Hey @developers1,

Thank you for reaching out to the Zoom Developer Forum. It looks like this is happening because the Web SDK requires that the application be served over HTTPS in order to use the microphone or camera.

When testing locally, you can use a took like Ngrok to create a secure, publicly accessible, URL for your local development server.

Please try accessing your application while using HTTPS (with a valid certificate) and let us know if your issue persists.


That maybe the case for the 1st issue (heres the link t that app ) , but it is not for the second issue where there is no sound but there is video.
Here is the link for the sandbox application.
We are not testing locally we have a AWS sandbox environment for both sites …

We fixed the issue. Here’s what we did:

Zoom issue fix process:
We are using web SDK packages for zoom integration with our app.
For the web package 1.7.10 some functionalities are not supported based on dependencies.
Now upgraded the version to 1.9.0.
Reference URL: https://marketplace.zoom.us/docs/sdk/native-sdks/web/release-notes

Hey @developers1,

Thank you for posting the fix you found here! This is due to a required update that came with version 1.8.5. You can read more about that update below:

I’m glad to hear that the latest version is working for you!


Thanks for the response.
It is working but there are some unexpected results. The screen has resized and is not fitting the screen. Particularly when you leave the meeting the option to end or leave doesn’t full display in the window it is off to the right hand side and you can only see 1/8 of the button.

Mobile 919.395.8140
USA office 919.341.1008

The contents of this e-mail message may be privileged and/or confidential.
If you are not the intended recipient, any review, dissemination, copying, distribution
or other use of the contents of this message or any attachment by you is strictly prohibited.
If you receive this communication in error, please notify us immediately by return e-mail or by telephone
and please delete this message and all attachments from your system.
Thank you.

READER BEWARE: Unencrypted, unauthenticated Internet e-mail is inherently insecure.
Internet messages may be corrupted or incomplete, or may incorrectly identify the sender.
Please contact us if you wish to arrange for more secure communication or to authenticate this message.

Hey @developers1,

Thank you for the update.

This could be related custom CSS styling that you have in your web app. I would test with our Sample Web App to see if you encounter the same issues. You can also use that app as a reference for your implementation.

I think that’s a great ideal! If you would like that feature to be considered for a future release, I recommend posting in the #feature-requests category.

On that same note, I’m going to move this topic over to our #client-web-sdk category as it seems best suited for that category.


Maybe these are new issues.
I am still not able to force all participants to a waiting room where the host will admin them.
The Gallery View button is not working. The view is default to gallery view and can not be changes while in the Zoom session
The Zoom session will not work on a iPad with a Firefox browser. I can see the presenter but their in no audio or video in the session. The error message I get is “Your Browser is not supported” .

Hey @developers1,

Thank you for providing more detail.

How are you placing users into the waiting room? Are you able to provide an example of the code you’re using and any errors that you encounter?

Are you able to send a screenshot of this issue? What browser are you using when you see this behavior and on what platform?

We do have limited browser support depending on the platform and browser that you’re using. Specifically, if you look at the iOS section you can see that Sending audio/video from the phone is not supported at this time. We plan to improve this support in the future but are currently blocked by the APIs available on iOS.

I’ll note that the Gallery View section of that documentation is incorrect. Currently, Gallery View is only supported when using Chrome or the latest version of Edge. We plan to expand browser support in the future.

I see that you have another forum post open with similar questions, please follow up in one of the two threads so we can keep information focused in one location.

Let me know if you have any questions.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.