Zoom Chatbot response: { code: 7004, message: 'Not authorized.' }

Using this template helps us debug your issues more effectively :slight_smile:

Description
I have been following this tutorial: https://marketplace.zoom.us/docs/guides/chatbots/build-a-chatbot
And cannot get past the response: { code: 7004, message: 'Not authorized.' }

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Chatbot

Which Endpoint/s?
https://api.zoom.us/v2/im/chat/messages

How To Reproduce (If applicable)
Steps to reproduce the behavior:
Request:

  url: 'https://api.zoom.us/v2/im/chat/messages',
  method: 'POST',
  json: true,
  body: {
    robot_jid: 'v1mghtw-x0qzgkvewhrezlzw@xmpp.zoom.us',
    to_jid: '4fnf7wsat_wsyyp8e4torw@xmpp.zoom.us',
    account_id: '10jr53ySQGy7cpLkWAHUog',
    content: { head: [Object], body: [Array] }
  },
  headers: {
    'Content-Type': 'application/json',
    Authorization: 'Bearer [REDACTED]'       
  }
}
  1. See error

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
I’m using a basic account - is that my problem?

Hi @xon52

Thanks for reaching out to Developer Support!!!

Can you please make sure that you have the following view and edit permissions enabled in your Chat settings?

image

Let me know if this helps.
Regards,
Elisa

Thank you for replying. I do not appear have those settings. I only have a basic account.
I checked in Profile - Setting.

Hey @xon52,

Thanks for checking. @elisa.zoom seems to be referring to the Chat Management permissions which can be found under a specific role from the Role Management page.

Essentially, you’ll want to make sure that your user has Chat Management permissions assigned to their role.

Let me know if that helps.

Thanks,
Max

Thanks for replying Max. For the third time, I am on a basic, free account.
That page states Prerequisites:

  • An Enterprise, Business, Education or Pro plan is required

I have entered my CC in just to see if options change and they do not. Either there is an account issue I have or the tutorial is not in fact possible using a free account (and should reflect that).

Hey @xon52,

I don’t think the Basic plan is the issue here. Instead, I would make sure that you are sending a Chatbot message to a user that has authorized the Chatbot already.

I hope that helps!

Thanks,
Max

I am developing this on the same account that I use for Zoom. I have followed the tutorial twice with the same result. Please see attached images for the settings of both my Personal profile and Admin management (they are both exactly the same).

Account Management → Account Settings → Zoom Apps
Screenshot_2

Account Management → Account Settings → Meeting → In Meeting (Basic)

Where else can I access relevant settings?

Hey @xon52,

Let’s set up a meeting so that I can make sure I understand the issue and we can debug this live. Please send an email to developersupport@zoom.us with a link to this thread and I’ll reply with a link to schedule a meeting.

Thanks,
Max