Zoom Meeting C# SDKERR_UNAUTHENTICATION

Description
While joining a meeting, getting error SDKERR_UNAUTHENTICATION

Which Windows Meeting SDK version?
zoom-c-sharp-wrapper-5.16.2.22857

Device:

  • OS: [Windows 10]

Additional context
I am using to generate JWT Token, token generating fine but getting SDKERR_UNAUTHENTICATION error while joining meeting, here is the complete code:

To Generate JWT Token: & To Authenticate SDK

To Join Meeting

Strange this is that with same code, Auth Success sometimes & meeting get joined but some times its giving Auth Error, so not understanding that if code is same for both conditions then where is the issue ?

Please let me know where is the issue

Thanks & Regards

Token Samples:

This token that worked:
eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhcHBLZXkiOiJObkl0dEUzTGhWbHlIbFIzajJzaUxqT3B3VndpMlA5VU1SaFYiLCJpYXQiOjE3MDUyMTQzODgsImV4cCI6MTcwNTMwMDc4OCwidG9rZW5FeHAiOjE3MDUzMDA3ODgsIm5iZiI6MTcwNTIxNDM4OCwiaXNzIjoiTm5JdHRFM0xoVmx5SGxSM2oyc2lMak9wd1Z3aTJQOVVNUmhWIiwiYXVkIjoiTm5JdHRFM0xoVmx5SGxSM2oyc2lMak9wd1Z3aTJQOVVNUmhWIn0.vlWQTyuVIt3Zu6MOL08kghMbBF9elzeSDGIDjyb38Dw

Token that not worked:
eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhcHBLZXkiOiJObkl0dEUzTGhWbHlIbFIzajJzaUxqT3B3VndpMlA5VU1SaFYiLCJpYXQiOjE3MDUyMTQyOTIsImV4cCI6MTcwNTMwMDY5MiwidG9rZW5FeHAiOjE3MDUzMDA2OTIsIm5iZiI6MTcwNTIxNDI5MiwiaXNzIjoiTm5JdHRFM0xoVmx5SGxSM2oyc2lMak9wd1Z3aTJQOVVNUmhWIiwiYXVkIjoiTm5JdHRFM0xoVmx5SGxSM2oyc2lMak9wd1Z3aTJQOVVNUmhWIn0.NAzT0MmmCoVhIpfSPo2I0YXgxk4jZAP0VbuezbHYzfk

@startwo8899 ,

Sometimes there might be some system time difference. I would try to set the IAT to be slightly 1-5 mins before current time.

nbf, iss, aud are not necessary parameters in the JWT token btw.

Do tag me @chunsiong.zoom in your response

@chunsiong.zoom ,

I tried this & tried by reducing time up to 30 min also, but there is still uncertainty, some times, it gets authenticated & some times getting error again & again, even if create new token again & again.

You can have a look on the code screen shot i posted above, I am generating this token using UTC time, so i think that is fine. Let me know what else I can do so that there will have surety about this authentication step & get connected fine.

Thanks & Regards,

@chunsiong.zoom ,
Please reply, I am stuck, this authentication has an uncertainty …

@startwo8899 can you remove the unnecessary fields?

  "nbf": 1705214292,
  "iss": "NnIttE3LhVlyHlR3j2siLjOpwVwi2P9UMRhV",
  "aud": "NnIttE3LhVlyHlR3j2siLjOpwVwi2P9UMRhV"

whats the version of SDK you are using by the way?

@startwo8899 ,

Could you also confirm if your SDK is from a meeting SDK app, and it is the ClientID (or SDK Key) found on marketplace.zoom.us?

Its Client ID & Client Secret of a Meeting SDK App

Changed generate JWT Token method like this now

Version of SDK:
zoom-c-sharp-wrapper-5.16.2.22857\x86

At the time of writing this message, it is connecting, but when it start throwing error is the concern…

@startwo8899 please tag me in your response

Could you check if your machine’s time is synced and accurate?

@chunsiong.zoom ,
Yes of course, its perfect & in sync state,
& as i said i tried reducing time by 5 min, 10 min, 15 min, 20 min, 25 min & more, but when it not work, reducing time rarely make it working.
& when it works, there is nothing done in code or system.
So it gets connected or not by its own wish, code is same, system is same…

@startwo8899 I’ll PM you to get more details