Zoom meeting not connected(Meeting ID generated is differed in API response)

Description
Meeting not getting connected

To Reproduce(If applicable)
Steps to reproduce the behavior:

We are receiving the success response while connecting the zoom meeting but the zoom sdk throws this popup Meeting id is not valid.

We have checked with the meeting creation API from the backend and we got success response on both video call as well as audio call. The audio call is working as expected in SDK. But the Video call wasn’t working because the Meeting ID generated is differed from the Join/ Start URL Meeting ID from Zoom response.

Zoom response:
Meeting ID : 96114869902
Join/ Start URL Meeting id: 2408917450

Please check the below API response screenshot and you can see the different meeting ID comes in meeting id and the join/ start URL.

This problem occurs only for a particular account while making a video call, Audio/ Video calls in other accounts are working as expected.

I have attached the sample request and response data below. Please check it.

REQUEST: {“topic”:“My Meeting”,“type”:“2”,“settings”:{“audio”:“voip”,“auto_recording”:“none”},“password”:“5XwDCqPR1r”}

RESPONSE: {“uuid":“srdcjz1htrs98w5mjeplfq==”,“id”:96114869902,“host_id”:“a0syfbvysrcf6wbkfakcea”,“host_email”:"patricia@invucare.com”,“topic”:“My Meeting”,“type”:2,“status”:“started”,“start_time”:“2020-12-16T10:09:54Z”,“duration”:60,“timezone”:“America/Phoenix”,“created_at”:“2020-12-16T10:09:54Z”,“start_url”:“https://care.zoom.us/s/2408917450?zak=eyJ6bV9za20iOiJ6bV9vMm0iLCJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiJBMHN5RmJWWVNyQ0Y2d0JLZmFrY0VBIiwiaXNzIjoid2ViIiwic3R5IjoxMDAsIndjZCI6ImF3MSIsImNsdCI6MCwic3RrIjoiRmI3bTluVXdCd2YzZ3RBYndpYW15VzZpMlF2Rnl1cWhqWXJYZEJaTV9VRS5CZ1VnZFhsbVJXWmFjbUYxUmtScU5UUkxMMEpXYVcxeFFpODJRMDU0V1VSb01scEFZemt3T0RFek5EVmlZalJtWVdKbE1EWTNORE5tWTJOaE1HVmhaamcxTldKbVlXUmhOV1F5WlRRelpUY3daRGhpWVdFeE1URTJZbVZtWlRWa016WTFZUUFNTTBOQ1FYVnZhVmxUTTNNOUFBTmhkekUiLCJleHAiOjE2MDgxMjA1OTQsImlhdCI6MTYwODExMzM5NCwiYWlkIjoiUlFsRDZNZGZRbU9mOFhqTkFIQldvQSIsImNpZCI6IiJ9.PAMoCHcjwg7RmMHbx_Y25t_kHWkqgEVwYJdh22AHRrQ",“join_url”:“https://CARE.zoom.us/j/2408917450?pwd=R1VweUFXRDVmKytGbzhYTnhEdG5Ndz09”,“password”:“5XwDCqPR1r”,“h323_password”:“9602519149”,“pstn_password”:“9602519149”,“encrypted_password”:“R1VweUFXRDVmKytGbzhYTnhEdG5Ndz09”,“pmi”:“2408917450”,“settings”:{“host_video”:false,“participant_video”:false,“cn_meeting”:false,“in_meeting”:false,“join_before_host”:true,“mute_upon_entry”:false,“watermark”:false,“use_pmi”:true,“approval_type”:2,“audio”:“voip”,“auto_recording”:“none”,“enforce_login”:false,“enforce_login_domains”:"",“alternative_hosts”:"",“close_registration”:false,“show_share_button”:false,“allow_multiple_devices”:false,“registrants_confirmation_email”:true,“waiting_room”:false,“request_permission_to_unmute_participants”:false,“registrants_email_notification”:true,“meeting_authentication”:false,“encryption_type”:"enhanced_encryption”}}

Just for info this account it was already activated and verified from zoom
Note: It is live account so please fix as soon as possible

Screenshots
647cf3ce8b4cc16fea93807384776855056805c4_2_230x500

Thanks!

Hey @m.nagarajanbtech,

This is because you are using a Personal Meeting ID. "use_pmi": true

Please let me know if my explanation here clears things up:

Thanks,
Tommy

Hi @tommy

I have checked in our backend for what data(boolean) we are sending in the “use_pmi” variable and confirmed that we have set use_pmi as false only(use_pmi" => false). I have attached that screenshot below.

Note: We didn’t create scheduled/instant/recurring meetings from backend. We are just creating the basic flow of creating a meeting by using the below input params.

Input param
{“topic”:“My Meeting”,“type”:“2”,“settings”:{“audio”:“voip”,“auto_recording”:“none”},“password”:“5XwDCqPR1r”}

Please help us to find why are we still facing the same issue for the particular account?

Thanks!

Hey @m.nagarajanbtech,

Thank you for providing additional information. Looking at the initial request body that you send, it looks like use_pmi was set to true. Please make sure that you aren’t setting this to true when testing through Postman. I would also make sure that the setting is disabled at the account-level.

I hope that helps! Let me know if you have any questions.

Thanks,
Max

Hi @MaxM

I’m quite confused about where is the initial request body. Because we have set use_pmi as false from the backend and then Implementing the API call.

Please check the below attached image clearly. So you can see all the use_pmi params are set to false only.

Could you please explain a little more about where exactly the problem exists?

Thanks!

Hey @m.nagarajanbtech,

Thank you for your question and my apologies for the confusion. What I meant is that in the response body, I was seeing use_pmi was set to true. Typically this is caused when the request itself has that field set. I just have a couple of questions from here to make sure I understand correctly:

  1. Does the account or user starting the meeting have either of the following settings enabled in the Zoom Portal?

  1. Does this request work as expected when you test from a REST Client such as Postman?

  2. Have you confirmed that the code hits the else if block where use_pmi is set to false?

Thanks,
Max