Zoom Meeting Web SDK Component View screen sharing layout issue

I am having an issue with the screen share layout having a really small screen for Meeting SDK for Web using component view. It is the same issue with this topic. I am using vue.js so I tried the vue sample app but it seems that the issue is still there.

Is there a way to make it look decent or even a possibility to make it full screen?

I am using the the latest Meeting SDK v2.8.0 for web


@Uhliber ,

When you say this issue is the same as this topic, you only see this behavior when the “host who made the meeting from outside shares the screen” ? Also, which browsers are seeing this behavior? And have you enabled SharedArrayBuffer enabled for your site?

Please let me know the steps to reproduce and I will look into this on my end.

For reference, here is a gif of the different views for the component view:
Zoom Web Meeting SDK Component View

You may also want to explore the following Component View resources :

Component view (SharedArrayBuffer enabled)



1 Like

Hi @donte.zoom,

I am using Chrome browser and SharedArrayBuffer was not enabled for my site. So I followed the instruction shown in the first resource that you shared. What worked to me is Implementing Credentialless Headers.

I added it in the middleware as shown in the code below.

public function handle(Request $request, Closure $next)
  $response = $next($request);
  $response->header('Cross-Origin-Embedder-Policy', 'credentialless');
  $response->header('Cross-Origin-Opener-Policy', 'same-origin');

  return $response;

Screenshot after implementation (Ribbon view and Gallery view are now also available)

Now, it’s working!
Thanks for your help!

Awesome, @Uhliber ! Glad you were able to resolve the issue and we appreciate you sharing your solution with us !

i had a similar problem, when participants join at first time looks fine, but when host shares the screen, the pop up gets wider like this, and i can’t control it.

did you experience the same?

@donte.zoom how i can fix this?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.