Zoom Navigation Controller Problem

Hello Team Zoom

I found this error while integrating SDK after auto generating join meeting id button …its not  display the view of video…

Warning: Attempt to present <ZMNavigationController: 0x7fdcb5956800> on <ViewController: 0x7fdcb3c46ac0> whose view is not in the window hierarchy!

please solve this problem

thank you

Hi Ananya, 

Did you tried to present navigationController within the viewDidLoad method? Please try to move this method into viewDidAppear method.


HI Wei,

we did the same but not find any luck.

Kindly suggest if there is any method to solve this issue.

Remove the following code in your project, and have a try again:

    **[[**MobileRTC sharedRTC] setMobileRTCRootController:navVC];

Note: if your app is not based on a UINavigationController as root view controller, the above code should not be added into your project.

Again no luck kindly suggest another method.

From the above mentioned descriptions, we cannot find the root cause. Could you send us your project and we can check it directly?


I’m facing this issue, did you solve it? please tell me how 

These are my App Delegate and View Controller…

This is an error causing zoom not to show up…

Quick help will be highly appreciated?

Hey @iqbalbhabha,

Thanks for using the dev forum!

The Zoom SDK does not support SceneDelegates. To be able to use the SDK you must remove the AppSceneManifest from the info.plist and remove the SceneDelegate.swift file.

Also, your screenshots were removed because they contained your SDK Key and Secret. Be careful not to make your SDK Key and SDK Secret public in the future. We advise you generate a new key and secret.


Thanks @Michael_Condon I did the following steps mentioned below still it didn’t work and throwing same error
Warning : Attemp to present <ZMNavigationController: 0x107986c00> on <FocusPoint.SplashViewController: 0x10730c890> whose view is not in the window hierarchy!

  • Completely remove the “Application Scene Manifest” entry from Info.plist.
  • If there is a scene delegate class, remove it.
  • If there are any scene related methods in your app delegate, remove those methods.
  • If missing, add the property var window: UIWindow? to your app delegate.

Hey @iqbalbhabha,

Sorry it is still not showing, that must be frustrating!

Another thing that could be happening is a navigation controller is not being provided to the SDK. Embed your ViewController in a NavigationController then pass your NavigationController to the SDK using:

MobileRTC.shared().setMobileRTCRootController( self.navigationController)

Try adding that and let me know what happens.