Zoom SDK native integration with Flutter

Description
What could be the reason behind app getting crashed while running app after natively integrating Zoom SDK in Flutter application for Android.

Which Android Client SDK version?
zoom-sdk-android-5.5.1.1319

To Reproduce(If applicable)
Steps to reproduce the behavior:
NA

Screenshots

Smartphone (please complete the following information):

  • Device: Redmi Note 7 Pro
  • OS: Android 9

Additional context
We are trying to add Zoom SDK natively in our Flutter app for Android.
We have included the required “commonlib” and “mobilertc” folders from extracted SDK and after completing the integration steps from the Zoom SDK website, when we run our app, the app crashes with an exception log (see attachment(s)). The app works perfectly with Zoom SDK while running in “debug” mode, but for the “release” mode version, the app gets crashed.

We have also included ProGuard configurations (found as a suggestion step on the Zoom developer forum), but still, the same issue persists.

Below are the tools used while working with Zoom SDK for Android:

  1. Zoom SDK (latest) - zoom-sdk-android-5.5.1.1319
  2. Android Studio IDE 4.2.1

Hi @rohitbhargava, thanks for using our SDK.

Unfortunately we do not currently support Flutter, so I am limited in how I can help with build-related issues. If you are able to reproduce this in a native Android app, I would be able to better assist. Usually if there are issues coming up only in release but not debug variants, it is likely that proguard rules must be added, but I can see that you have already tried this. Can you post the rules you have added for the SDK so I can confirm that everything you need has been added?

Thanks!

Hi @jon.lieblich
Thanks for your response.

Following rules were added in ProGuard file:

-keep class us.zoom.** { *; }
-keep class com.zipow.** { *; }
-keep class us.zipow.** { *; }
-keep class org.webrtc.** { *; }
-keep class us.google.protobuf.** { *; }
-keep class com.google.crypto.tink.** { *; }
-keep class androidx.security.crypto.** { *; }

We have tried testing with earlier ZoomSDK versions,but still the same exception is occurred.

1 Like

Hi @rohitbhargava,

The content of your proguard file looks correct. Are you certain that this is being properly applied to your project?

Thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.