Zoom V2 API returning XML from create_meeting endpoint?

I was under the impression that the V2 Zoom API was a JSON API. Users of our application were running into issues this morning, and it turns out that it’s because the back-end library we use to make HTTP requests was crashing when attempting to parse response bodies into JSON. After logging what the response was, we observed the response body to look like:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><result><code>300</code><message>Validation Failed.</message><errors><field>password</field><message>Password provided does not match the password requirement settings set for this account. The password must follow these rules: [Password must contain only numeric characters.].</message></errors></result>

Why is the response coming through as XML from the V2 create_meeting endpoint? Did the wires get crossed between the V1 and V2 APIs?


Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT app

Which Endpoint/s?
Create meeting

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Make a request to the V2 create meeting endpoint that does not meet the password requirements for the Zoom user in question
  2. Get an XML response

Hi @elyes,

Can you please send us a sample request that returned this error? If it contains any private information, can you please send it to developersupport@zoom.us ?


I am facing the similar issue when I tried to use Create Meeting API endpoint with an invalid password

Endpoint: Create Meeting
Scenario: Entered password having less than 8 characters.
Headers: Content-Type:application/json
Request Body:
“topic”: “Test My Meeting”
,“start_time”: “2020-08-28T12:00:00Z”
,“duration”: “60”
,“timezone”: “Asia/Calcutta”
,“password”: “1234567”
,“agenda”: “Discussion about Me”
“approval_type”: 0
,“registrants_confirmation_email”: “true”
,“registrants_email_notification”: “true”

Header: Content-Type: application/xml;charset=UTF-8

Response Body:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?> 300 Validation Failed. password Password provided does not match the password requirement settings set for this account. The password must follow these rules: [Password must have a minimum length of 8 characters.].
1 Like

Hi @sardar.chayan,

Can you please provide the following in your request headers?

accept: application/json

This should resolve the issue.


Thanks @ojus.zoom
This did the trick :slight_smile:
Well previously it did work without this header. I presume there were some changes in the latest Zoom API upgrades.

Hey @sardar.chayan,

Glad to hear it’s been sorted! Let us know if anything else pops up. (and thanks @ojus.zoom!)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.