Zoom web sdk not rendering currently in mobile browsers

Description
Zoom Web-SDK is not rendering properly in mobile browsers, especially during chat, while the mentor is sharing the screen , the UI is not clearly visible for viewers . Here i am talking about only webinars :slight_smile:

Which Web Client SDK version?
1.9.1

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Try to join the webinar from mobile browser.

Screenshots


Device (please complete the following information):

  • Device :POCO M2
  • OS: Android 10
  • Browser: Chrome
  • Browser Version [e.g. 89.0.4389.105]

Additional context
The major fix which we want is like when ever the mentor is sharing the screen the viewers should get the sharing screen fit to screen by automatically minimizing the mentor tile, can we do that, i have tried all options provided in web sdk Link

Can you please help on this or any reference for how to fix these issue which are occurring in mobile web versions.

Hey @vasanth,

Thank you for reaching out to the Zoom Developer Forum. When you see this issue, are there any errors in the browser console? In my testing, I haven’t seen this same issue.

I would test with our Sample Web App to see if you encounter the same issue. You can also use that as a reference to catch any potential issues.

Thanks,
Max

Hi @MaxM , I have followed your sample web app only when setting up for my project, Coming to your question, I am not getting any console errors, everything is fine, but the main problem is when the host is sharing the screen the audience viewing experience is not good, if you see the second screenshot which i attached , you will get that clarity. We want to minimize the host tile by default, when the host is sharing the screen, can we do that by providing any configuration options?
The aim is to make our viewers experience smooth in mobile browser view .

Hey @vasanth,

Thank you for the update. Just to make sure I’m clear, the issue that you’re seeing is that the screen sharing window on mobile browsers is too small, is that correct? If so, this is a known issue that I’ve reported to our engineering team. I was informed that this is intended in order to allow the entire screen sharing window to display. This is something we will work to improve in the future.

In the meantime, you should be able to minimize the webcam preview window (the one that says sai) in order to expand the size of the screen sharing window.

Let me know if that helps.

Thanks,
Max