ZoomMtg.join() returns "The signature has expired."


I’m testing out the sample-app-web js app from github.

I have ZoomMtg.generateSignature() returning a signature okay.

ZoomMtg.init() is getting to the success function okay.

But ZoomMtg.join() is resulting in an error:

{method: “join”, status: false, errorCode: 1, errorMessage: “The signature has expired.”, result: null} 

Anyone any ideas.



So I decided to step through in chrome’s debugger to see what was happening inside and all of a sudden no error and the meeting starts.

Go back to not debugging and the same error again.

So suspecting a race condition I wrapped ZoomMtg.join() in a setTimeout with 5000ms.

Works fine then.

That was yesterday.

Today I’ve removed the timeout and have no problems at all.

If there is a race condition happening somewhere then it’s not happening today. :frowning: But I fear it could return at some later point.

Anyone experienced this with the sample app?


Hi Iain, 

Looks like there is a bug within our sample web app, what OS does your computer have?


Hi Michael,

I’m running:

Windows 10 Enterprise - 1803 - 17134.286
Node - v9.4.0
Chrome - 69.0.3497.100


errorCode: 200
errorMessage: “The signature has expired.”

Interesting KB. So it’s still happening, for you at least.

I’m no longer seeing the “Signature expired” error myself.

Let me try throttling my bandwidth maybe?

Nope still can’t get it to happen. Even when connecting before the three wasm modules are preloaded.

I’m not sure what’s changed between when I did get it and not.

I was using an different account and api key/secret before, let me switch back to that.

Nope. Still working. Hard for the guys to fix if we can’t replicate it.

There’s two change’s I’ve made to the sample app:

Adding an error handler to join.

And setting role to not be host (0), as I was hosting with a different account for testing purposes.


Hi Iain, 

Thanks for providing us the details. Looks like there is a bug within Chrome for Windows that you have to use a set timeout. We have alerted our developers about this so we can fix this asap. 


@Iain M Norman After error handling and role 0 still same error and @Michael Purnell I have used setTimeout but that also not useful.  As per chatting with support they said this is due to trial license but I think then error should be different.

Hi KB, 

Can you try this to see if this resolves your issue? Within the Chrome inspector, set a breakpoint where ZoomMtg.join meeting is. When you click the Join button, wait for about 5 seconds then resume. Also, I’m assuming you are working on Windows correct?


I’ve removed my setTimeout workaround and am no longer getting the original problem.

The same issue, on Mac (Chrome & Safari) & Win 10

Some more info.

I only had this problem when I had a free dev account. I’ve taken out my workaround and have not been able to replicate since my client gave made me a dev on their business account.

1 Like

I am facing the same error,
Is there any workaround?

In Ubuntu, it’s working fine
No idea what the actual issue is.
I am attaching the image as a reference.

OS: Windows 10.
Browser: Chrome Version 72.0.3626.119
Error: image

OS: Ubuntu 16.04
Browser: Chrome Version 67.0.3396.62 (Official Build) (64-bit)
Working fine.

cloned the repo.
changed api key and secret
cd CDN
npm install
npm start
entered the meeting id and name

you use the jssdk 1.3.0 version. please update last version.

hi, I didn’t change the version but somehow it’s working now in windows too.


Hi,I made that and work for me but the question is, how can I integer the setTimeOut in my code? or what I have to do for solve it?

Hi @magh92,

We have received your request and will update you shortly.


Hello any update on this concern?

Hi @carloskekwa,

Are you using the sample web app to generate your signature or are you generating a signature from the backend? Are make sure to not use your PMI when joining a meeting as an attendee.


Hello any update ?
I use the sample web app to generate the signature and my os is macOS and i still have the same issues