ZoomMtg.join() returns "The signature has expired."

Hi,I made that and work for me but the question is, how can I integer the setTimeOut in my code? or what I have to do for solve it?

Hi @magh92,

We have received your request and will update you shortly.

Thanks

Hello any update on this concern?

Hi @carloskekwa,

Are you using the sample web app to generate your signature or are you generating a signature from the backend? Are make sure to not use your PMI when joining a meeting as an attendee.

Thanks

Hello any update ?
I use the sample web app to generate the signature and my os is macOS and i still have the same issues

Hey @r.abdelhamed,

Please see my reply to your post here:

Please also refrain from double posting.

Thanks,
Tommy

Dears,

Thanks alot it solved

I used your signature example app and it is worked

1 Like

Happy to hear you got it working! :slight_smile:

Thanks,
Tommy

Hello Tommy,

We are facing same problem in windows 10 os can you please provide the signature example app to us.

Thank You…

Hey @kumkumschool,

Here are instructions to generate the signature, and the sample app:

Thanks,
Tommy

Hello guys
I’m having the same issue here, generating the signature using the websdk or manually implementing the code mentioned here. I don’t see a solution on the web, I noticed that most of the times the error just goes away for the ones who had the problem without implementing any solution.

any advice ?

Hi @ramy.dridi

Most of the times the issue is because the laptop date and time settings are not correct. Either the time is not correct or timezone is not correct. Once you rectify this and set the time to auto sync, this should get resolved.

Hello @helloparent , Thank you for replying!
so I read that generating the signature on the server might fix the problem. however, fixing the date/timezone of the server means that I should set the right timezone for it depending on its place? is that it?
thank you again!

For us setting the timezone of the computer/laptop on which the SDK is running right solved the issue.

I guess that’s not practical for my case. the app will be used by hundreds each day and fix the date/timezone is a bit handy for me of users (yeah, believe me)

anyway, thanks for your input, I’ll try the backend solution and will leave the solution here if it works, thank you again!

Hey @ramy.dridi,

Were you able to get it working?

Thanks for your input @helloparent! :slight_smile:

Thanks,
Tommy

Hello,
the problem is the timezone as mentioned before, so I started testing different timezones, and also trying to add/remove some milli-seconds depending (I sync with https://time.is/) and I then generate the signature on the server as mentioned here as a solution, but what I did is for testing purposes only.

so bottom line, you need to have the exact same time as your timezone time.

Happy to hear you got it working! :slight_smile:

-Tommy

@tommy I am using the latest Websdk version 1.8.1 for my Angular and C# project. I generated the signature using given example here: https://marketplace.zoom.us/docs/sdk/native-sdks/web/build/signature

It is working fine on local but after deploying it on the production IIS server, it is giving The signature has expired. with Error code 3705 error. The server’s timezone is UTC + 5:30.

I tried in Firefox and as well in Chrome brower.

Can you please help me to sort out this issue asap?

Hey @dipapatra2012,

Can you please see if it works with just UTC time? The 5:30 + is most likely causing the issue.

Thanks,
Tommy