Joining meeting timeout

Hi Tommy

I have updated the webSDK to 1.7.4 , and yet still succession with the functionality

please help

Hi @nick1,

Please update to version 1.7.5. If you still see an error, please DM me your account ID and API Key/Secret.

@tommy , I’m more of a project manager than a developer so I apologize for any incorrect terms here, but I’m just trying to get an understanding of things.

  1. Is this post still the best place to go ask questions about recent issues of embedding zoom into a webpage? This functionality is really important to us and I can only imagine others as well (anyone who wants to embed a meeting into their website, which would seem to be a huge number of people!).

  2. As I understand, until a week or so ago, I believe my developer used to iFrame Zoom into our webapp. It seems you are saying now that going forward Zoom is now developing an SDK instead? So, basically an SDK as I understand them would give us more control over Zoom functionality, right – as opposed to only iFraming the exact interface? We can get by without more advanced SDK an instead just have the iFrame option back, but I am assuming iFrame is being abandoned because of security reasons?

  3. Is there any detail on an ETA to have a solution where we can embed Zoom with our apps or does it still work and I am missing something? From the page you cited it looks like sometime this month? (April, 2020)? Could we expect maybe sometime this week even?

Will

Hey @wgardner,

For questions about the Web SDK yes. :slight_smile:

We already have the Web SDK, and it is the currently supported way of embedding Zoom into a website.

The Web SDK is working. :slight_smile:

Thanks,
Tommy

1 Like

Hi @michael_p.zoom
i update to version 1.7.6 and i still have the same error ‘Joining meeting timeout.’ with ‘‘The signature has expired.’’
i use the free account

Hey @r.abdelhamed,

Please private message me your signature and I will debug.

Also see this thread:

Thanks,
Tommy

Dears,

Thanks alot

I issue is solved. I used the your
signature example App and it work with me

1 Like

Happy to hear you got it working! :slight_smile:

-Tommy

How exactly did you get it working? I’ve just installed the latest
git@github.com:zoom/sample-app-web.git, replaced the api token and secret with my credentials and am seeing the “Joining meeting timeout” message.

Did you implement your own signature creation function with the “signature example App”?

Presumably the existing sample app should work as is (given that it is an example of how to integrate with Zoom)

Hi Russ,

There is an issue with Free/Basic accounts being able to join meetings via the WebSDK. A workaround would be to upgrade your account to a Pro Account to avoid.
Let us know if this works for you.

Thanks

Hi @russ

Yes I work with free/basic zoom account
and yes, it works by implementing my own signature using the “signature example App” from my backend code to generate the signature with every meeting id

the existing SDK sample app work but the signature which generates by it has a different time zone than my time check this ticket “Join meeting timeout or signature expired

1 Like

Ah, I’ll take your word for it (I don’t really want to sign up for Pro just to test a bug)

Assuming that would resolve it, might be an idea to show that in the error message too (rather than a timeout)

Thanks for responding!

Hey @russ,

You can also request a free trial here: isv@zoom.us.

We are working on improving the error messages. :slight_smile:

Thanks,
Tommy

hi there I have exact problem and I can’t find a solution for fix it. It was works like a spaceship and now I get this timeout error. I didn’t change anything and I don’t know how to change signature or even I don’t know where I should look… please help me I am on the egde:(

Hi there,

could you please confirm webSDK is not working if the meeting is created by a free account ?
i’m trying it and get this “join timeout” everytime.

regards

Hi @serdarkaksi

What account type do you have Free or Pro? Are you using you PMI or newly generating meetings?

@VincentV Please upgrade to a Pro account. We’re having issues with Free accounts using the WebSDK?

1 Like

Thanks Michael, but I don’t want to pay for a pro account to developp a website for one of my client.
I will check with my client if they can share their pro account.

regards

I upgrade my account to pro version with montly payment 15$ I hope this will fix my problem otherwise I have to demand refund.

I have the same problem over here. It started when it was here (Germany) just past midnight and the meeting i was trying to connect to was hosted in Canada, which is 6 h behind. So i was at a different day than the hosted meeting. Before midnight everything just worked fine. We suspect that might have caused a problem. Right now its here and there the same day (here 1PM, over there 7am) and i’m connected without an issue. Might be worth to have a look.

Hi there

I got this error if I init webSDK with the same email address (userEmail) that my zoom account email address. It makes sense.
Using any other userEmail it works as expected.