AAPT: error: resource style/TextAppearance.Design.Tab (aka com.example.zoomvideo:style/TextAppearance.Design.Tab) not found

Android resource linking failed Android Studio

Hi adersh.v,

Thanks for using Zoom SDK. Could you provide more information on how you get this error? Did you follow the instruction here https://marketplace.zoom.us/docs/sdk/native-sdks/android/getting-started/integration to integrate the SDK into your project? Is this reproducible with our demo app? If yes, could you provide the steps to reproduce this?

Thanks!

Yes I have followed the steps. While running the application I am getting this error.

Step followed
Download the sdk
Added the module with the project.
Create a project and gets the sdk key and sdk secret then add to project.

Initialise the zoom, meeting parama etc.
Start meeting.
At the time of running the project I am getting this error

i have added zoom sdk as module dependency . without adding any other codes after rebuilding the project i am getting this error , only after adding zoom sdk as module dependency .
Android studio version 3.6.1
Min Api 21
Max Api 29

I’m getting same issue, I followed instructions carefully but i still getting this issue at compilation.
I realize that, After adding module dependency i’m getting error

Android resource linking failed
project_source_path…/mobilertc/build/.transforms/7c2831cfa1bacdd7dd0f51b8489c7fc7/jetified-mobilertc/AndroidManifest.xml:129:9-133:51: AAPT: error: attribute android:foregroundServiceType not found.

I’m using
compileSdkVersion 28
buildToolsVersion ‘28.0.3’

minSdkVersion 21
targetSdkVersion 28

dependencies {
implementation ‘androidx.multidex:multidex:2.0.0’
implementation ‘androidx.recyclerview:recyclerview:1.0.0’
implementation ‘androidx.appcompat:appcompat:1.0.0’
implementation ‘androidx.constraintlayout:constraintlayout:1.1.3’
implementation ‘com.google.android.material:material:1.0.0-rc01’
implementation project(’:commonlib’)
implementation project(’:mobilertc’)

implementation fileTree(dir: 'libs', include: ['*.jar'])
implementation files('libs/YouTubeAndroidPlayerApi.jar')
implementation files('libs/jackson-core-2.7.3.jar')
implementation files('libs/jackson-databind-2.7.3.jar')
implementation files('libs/jackson-annotations-2.7.3.jar')
implementation 'androidx.appcompat:appcompat:1.0.0'
implementation 'androidx.cardview:cardview:1.0.0'
implementation 'androidx.legacy:legacy-support-v4:1.0.0'
implementation 'androidx.palette:palette:1.0.0'
implementation 'androidx.work:work-runtime-ktx:2.0.1'
implementation 'androidx.constraintlayout:constraintlayout:1.1.3'
implementation 'com.github.PhilJay:MPAndroidChart:v3.0.2'
implementation 'com.google.android.material:material:1.0.0'
implementation 'com.google.firebase:firebase-messaging:20.1.0' // fcm messaging
implementation 'com.google.android.gms:play-services-auth:17.0.0' // google login
implementation 'com.facebook.android:facebook-login:[5,6)'
implementation 'com.github.bumptech.glide:glide:4.3.1'
implementation 'com.github.chinalwb:are:0.1.5'
implementation 'com.github.chrisbanes:PhotoView:2.1.3'
implementation 'com.razorpay:checkout:1.5.12'
implementation 'com.github.barteksc:android-pdf-viewer:3.0.0-beta.5'
implementation 'com.google.android.exoplayer:exoplayer:2.11.2'
implementation 'com.google.android.exoplayer:extension-rtmp:2.11.2'

implementation 'com.jakewharton:butterknife:8.0.1'
annotationProcessor 'com.jakewharton:butterknife-compiler:8.0.1'

}

Please provide any resolution to help.
Thanks

Hi adersh.v,

Thanks for the reply. Please follow refer to the configurations in https://github.com/zoom/zoom-sdk-android/blob/master/mobilertc-android-studio/sample/build.gradle to configure your build.gradle file. Please make sure that the compileSdkVersion is 29 and the buildToolsVersion is 29+ as mentioned in https://github.com/zoom/zoom-sdk-android#latest-sdk-notifications

Hope this helps. Thanks!

1 Like

Hi mdsafdarsaleem,

Thanks for using Zoom SDK. Please make sure that the compileSdkVersion is 29 and the buildToolsVersion is 29+ as mentioned in https://github.com/zoom/zoom-sdk-android#latest-sdk-notifications.

Hope this helps. Thanks!

1 Like

Thank you very much, It is working after updated to buildToolsVersion & compileSdkVersion to 29.

Glad to hear that it is working. Happy Zooming! :slight_smile:

1 Like

apply plugin: ‘com.android.application’

android {
compileSdkVersion 29
buildToolsVersion “29.0.2”

defaultConfig {
    applicationId "com.example.videochat"
    minSdkVersion 21
    targetSdkVersion 29
    versionCode 1
    versionName "1.0"
    multiDexEnabled true

    testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner"
}

buildTypes {
    release {
        minifyEnabled true
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard.cfg'
    }

    debug {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard.cfg'
    }
}

lintOptions {
    checkReleaseBuilds false
    abortOnError false
}
compileOptions {
    sourceCompatibility JavaVersion.VERSION_1_7
    targetCompatibility JavaVersion.VERSION_1_7
}

}

dependencies {
implementation fileTree(dir: ‘libs’, include: [’*.jar’])

implementation 'androidx.appcompat:appcompat:1.1.0'
implementation 'androidx.constraintlayout:constraintlayout:1.1.3'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'androidx.test.ext:junit:1.1.1'
androidTestImplementation 'androidx.test.espresso:espresso-core:3.2.0'
implementation project(path: ':commonlib')
implementation project(path: ':mobilertc')

}

i am using this . but still the same proble

Hi adersh.v,

Thanks for the reply. Based on the gradle settings, everything looks good for those do exist in the gradle files in our demo app. So the issue might not from the dependencies. Hope this helps. Thanks!

@adersh.v I had the same problem adding this line to gradle helped me "implementation ‘com.google.android.material:material:1.0.0-rc01’ "

Hi vignesh,

Thanks for the reply and thanks for helping out! Yes, I just noticed that the dependency “com.google.android.material:material:1.0.0-rc01” is missing and it is required for using Android SDK.

Thanks!

@Carson_Chen You are welcome :v:

Hi adersh.v,

Please try to add com.google.android.material:material:1.0.0-rc01 in the dependencies as vignesh mentioned above and see if it helps.

Thanks!