Accepting incoming sip phone calls

#1

If a SIP phone dials in with the iPad app, it prompts the user to accept or reject it. But it seems like with the API, I dont see a way to accept these phone calls. I have tried passing the PeerURI and the callerID back to the zCommand Call Accept callerJID: command, but I cant seem to get it to accept my call and am getting invalid value, xxxxx is my phone number.

Declining an incoming phone number, should I use zCommand Dial PhoneHangUp ?

Jan 23 12:23:25.256
#### SSH Device Write ####
“zCommand Call Accept callerJID: xxxxxxx@199.255.120.176\r”

Jan 23 12:23:25.272
#### SSH Device Response ####
"
zCommand Call Accept callerJID: xxxxxxxxx@199.255.120.176

\r\n"

Jan 23 12:23:25.338
#### SSH Device Response ####
"*r AcceptResult(status=ParameterError):

*r AcceptResult CallerID: "Invalid value"

** end

ERROR
\n\n"
0 Likes

#4

The problem had to do with a new feature implemented in the Mac version of the Zoom Room which would decline a call if a controller capable of answering the call was not connected. Unfortunately, ZAAPI was not included in the list of controllers, so the Zoom Room would automatically decline the call.

This issue has been resolved and the fix will be released with the next release (planned for Sunday 1/27/2019).

0 Likes

#5

This problem still exists in the official release. I assigned a Zoom Voice number to my Zoom Room and tried calling in. I get the PhoneCallStatus response with a callID and valid info, but there’s no command to accept an incoming SIP call. zCommand Call Accept callerJid: xxx doesn’t work with the callId from the last response. I can see and hear it ringing on the Zoom Room, but I have no way to answer it.

0 Likes

#7

Hello Jeffrey, yes the problem seems to still be there. Our team is currently investigating this issue.

0 Likes

#8

Two customers complaining. #ftw!!

0 Likes

#9

Any updates on this? I finally got my UI to render an ACCEPT/REJECT screen for SIP calls and have buttons ready to fire a command whenever there is a new command available.

0 Likes

#10

This problem is a bug in the Zoom Room: the bug number is:

ZOOM-72143: Cannot Accept Incoming Sip Call

Unfortunately, there is no work-around. A fix for this bug is not planned for the next release of the Zoom Room. At the moment, we do not have plans for a beta build in the near future.

-Scott

0 Likes