Account does not support API error

#1

Hey All,

Im trying to hook up Zoom within our application, doing a little poc, but i am running into some issues quite early in the proces.
I’m trying to follow the steps in this tutorial: https://marketplace.zoom.us/docs/sdk/native-sdks/Web-Client-SDK/build-your-first-app/preperation

but when i try to join a meeting i end up with the error “The account don’t enable API”.

i tried several different things, tried to upgrade the version of the npm package so that it might connect to v2 of the api, rather than v1. didnt work.
Was looking through my account to find a setting to enable api, couldnt find it
the account is on a trail period so it should have the correct rights.
attached a screenshot of the browser with an attempt.

Im using ZoomMgt for this, the issue might be resolved if i bypass this and try to access the api v2 myself but ZoomMgt is still hooked up with v1 and i was hoping to still use this framework

#2

Hi @arnout.wind

Thank you for reaching out to Zoom Developer Support Forum.

Please make sure that within your Zoom portal under Role management -> Role Settings -> Zoom for Developers are selected and have that members for your account have that as a role.


Please let me know if you have any questions.

Thanks,
Ojus

#3

Thanks for the reply, so i tried.
As i was owner, i could not change myself to developer, so i added another person to the users and made him developer.

We tried making him meeting host, still the same error when we joined his meeting.
We added his api key and secret to connect to his meeting, sadly still the same error

basicly im not doing anything different from this repo: https://github.com/zoom/sample-app-web

except for the prefil of the meeting room ID and the filling of the API_KEY/API_SECRET as they are found in here:
api-creds

#4

Hi @arnout.wind,

Can you please reply to me via DM, the email address associated with your zoom account?

Thanks!

#5

Wish i could:
DM

and as a reply:
Yes the email address is indeed associated with my zoom account.
i was also wondering, in the sample-app-web application, do i have to run the app from the “Local” folder or from “CDN”, have always been running from the local one, tried cdn yesterday but that localhost:9999 wont even run

#6

Hi @arnout.wind,

Apologies for the inconvenience.

Replied to you via DM.

You should be able to run the sample web app from both i.e. Local and CDN. To know more, please visit our quickstart guide for the sample web app here : https://github.com/zoom/sample-app-web#quick-start

Let me know if you have any other questions.

Thanks!

#7

Hi @arnout.wind,

It looks like your using client ID and secret. You will need to use, developer.zoom.us API JWT app with API Key/Secret instead of Client ID and Secret. Please refer to this link, for step by step directions. Let us know if you need any additional help.

1- https://marketplace.zoom.us/docs/sdk/native-sdks/Web-Client-SDK/getting-started/prerequisites#obtaining-your-sdk-credentials

Thanks
Michael

1 Like
#8

cool, that did indeed work, i thought i already updated this everywhere but it seemed i missed out on one location.

So i get to join the meeting now, i have a little question about the screensharing, want me to open a new topic for this?
basicly when i init the session i pass this:
ZoomMtg.init({
screenShare: true,

but the screenshare button does not appear sadly

#9

Hi @arnout.wind,

I replied back to your question here - Web SDK Screen sharing.