Add Meeting Registrant - optional fields not posting

I was trying like crazy to figure out why phone, city, state, etc. are not posting when I created a new meeting registrant in my web app. I did not see any API format changes so dropped back and use the embedded Postman templates on the Zoom API doc pages to register an attendee and then list that attendee. It turns out that it’s not my App … it’s on the Zoom side of things. My meeting does not have custom questions so I expect that data to not post.

Submitted to registration endpoint:
https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingregistrantcreate

{
“email”: “myemail@mycompany.com”,
“first_name”: “Mike”,
“last_name”: “Brown”,
“address”: “123 Main ST”,
“city”: “San Jose”,
“country”: “US”,
“zip”: “95550”,
“state”: “CA”,
“phone”: “111-444-4444”,
“industry”: “Tech”,
“org”: “IT”,
“job_title”: “DA”,
“purchasing_time_frame”: “More Than 6 Months”,
“role_in_purchase_process”: “Influencer”,
“no_of_employees”: “1-20”,
“comments”: “Excited to host you.”,
“custom_questions”: [
{
“title”: “Favorite thing about Zoom”,
“value”: “Meet Happy”
}
]
}

Registration response

{
“id”: 82423xxxxx,
“join_url”: “https://us02web.zoomxx.us/w/82423xxxxx?tk=”,
“registrant_id”: “SCSit9JJRCaJLJUMxxxxx”,
“start_time”: “2021-12-01T16:00:00Z”,
“topic”: “OMS Test Meeting”
}

Response from Request to list participants
https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingregistrants

{
“page_count”: 2,
“page_number”: 1,
“page_size”: 30,
“registrants”: [
{
“address”: “”,
“city”: “”,
“comments”: “”,
“country”: “”,
“create_time”: “2021-04-06T22:56:21Z”,
“custom_questions”: ,
“email”: “myemail@mycompany.com”,
“first_name”: “Mike”,
“id”: “SCSit9JJRCaJLJUMxxxxx”,
“industry”: “”,
“job_title”: “”,
“join_url”: “https://us02web.zoomxx.us/w/824239xxxxx?tk=”,
“last_name”: “Brown”,
“no_of_employees”: “”,
“org”: “”,
“phone”: “”,
“purchasing_time_frame”: “”,
“role_in_purchase_process”: “”,
“state”: “”,
“status”: “approved”,
“zip”: “”
},

Hi @OregonDean,

Thank you for raising this with us—this seems strange to me as well. We’re looking into this for you (ZOOM-264348).

Thanks, and I’ll be in touch,
Will

Thanks, @will.zoom. I look forward to your feedback.

Thanks, I’ll be in touch shortly!

Hi @OregonDean,

After checking with my team, they’ve clarified that this behavior is the result of fields like phone, city, state, etc. not being selected as options for the meeting. Once these are enabled, you should see the API post this data correctly.

For example, if these options aren’t checked off, this would be expected:

You can access these options by following the steps under the Questions section here:

I hope this helps to clarify!
Will