Android SDK will not initialise in new Android Project App

Hi All,
New to the Zoom Android SDK and having trouble building a new app, after successfully building and running the sample.

Description
Project/App builds fine, but the app cannot initialise the SDK.
I have retained the code InitAuthZoomSDKHelper and InitAuthSDKActivity in the new app, and use this. However, the onZoomSDKInitializeResult function is never called from the helper, and the SDK is never initialised.
I have correctly imported the commonlib and mobilertc archives, and set the dependencies and the code builds fine. It is just at runtime the SDK fails to initialise.
As stated, the sample app from the SDK builds and runs fine.

Which version?
SDK: 2020-06-30 @ v5.0.24433.0616
Android Studio: 4.0

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Create a blank Android Project/App
  2. Import commonlib and mobilertc archives as per SDK docs.
  3. Import selected components from the “sample” SDK app
  4. Build the app
  5. Run the app in debug with a breakpoint after SDK initialisation.
  6. See code fail because SDK is not initialised.

Smartphone (please complete the following information):

  • Device: Pixel 2
  • OS: Android
  • Version 10

Additional context
Add any other context about the problem here.

Hi All,
I have tried now several projects with the SDK imported. None can initialise the SDK. Only the sample apps provided.
Any assistance would be greatly appreciated.
Cheers

Hi @john.a.stevens,

Thanks for using Zoom SDK. Based on the steps provided, it seems like everything is looking good but there is one thing that is missing: Did you add ZoomSDKInitializeListener to your class that calls the SDK initialize and has the onZoomSDKInitiazeResult callback?

Thanks!

Hi Carson,
Originally, I took the “sample” app in it’s entirety into a new Project, so yes.
Then when I created a completely clean project and followed all the SDK instructions I did call the SDK initialize and implemented the InitializeResult callback. Still no joy.
Cheers

Essentially, in all cases except in the mobilertc-android-studio project that comes with the SDK with examples, the onZoomSDKInitializeResult callback is never called. I am at a complete loss.

I have been modifying the “sample” app to try and progress on what is an urgent app to be developed by the end of this coming week. I have been unable to make the scheduled meetings list (PreMeetingExampleActivity created) clickable, which I need to have to start meetings from that view.
Can you please advise the best way to do this?
I have altered the layout XML to add both clickabel and focusable true, but no matter what I cannot ever trigger any form of onItemClick(). If I add an onClick listener to the ViewHolder sub class of MeetingsListAdapter, I can capture the clicks, but cannot decipher the item to fetch the meeting ID and password to begin the meeting.
Any advise on this would also be appreciated.