Zoom SDK fails to initialise

I have downloaded the SDK from GitHub and also successfully added all the required values in constants file in both the given examples --> example2 and sample. However, here’s the problem I am facing. When I build and run the example2 app and click on Meeting I get the following error “ZoomSDK has not been initialised successfully” and when sample app is run "Failed to initialise ZoomSDK. ErrorCode: 1, Internal error ". I have put in the correct SDK Key and Secret, along with JWT token and also the correct userID, UserToken and the Meeting ID is personal and is also correct. I have verified my credentials at least 3 times and tried over, but unfortunately it still gives me the same error.

Which version?
ZoomSDK Version - 4.6.21666.0429
Android Studio Version - 3.6.3

Smartphone :

  • Device: Emulator - Pixel 3a
  • OS: API Level 25
  • CPU: x86 Google Play Intel atom

Hi vk.rahul318,

Thanks for using Zoom SDK. Could you have a try with the following:

  1. In https://github.com/zoom/zoom-sdk-android/blob/master/mobilertc-android-studio/sample/src/main/java/us/zoom/sdksample/initsdk/AuthConstants.java, fill in the SDK_KEY and SDK_SECRET with your SDK credentials
  2. In https://github.com/zoom/zoom-sdk-android/blob/master/mobilertc-android-studio/sample/src/main/java/us/zoom/sdksample/initsdk/InitAuthSDKHelper.java#L41, comment out this line and add the following:
 ZoomSDKInitParams initParams = new ZoomSDKInitParams();
            initParams.appKey = SDK_KEY;
            initParams.appSecret = SDK_SECRET;
//            initParams.jwtToken = SDK_JWTTOKEN;
            initParams.enableLog = true;
            initParams.logSize = 50;
            initParams.videoRawDataMemoryMode = ZoomSDKRawDataMemoryMode.ZoomSDKRawDataMemoryModeStack;
            mZoomSDK.initialize(context, this, initParams);
  1. Build and see if the SDK initialization result. If the SDK is able to initialized, then it means your SDK credential works, and the issue is on the JWT token itself. If the SDK is not able to initialized, then your SDK credentials might have some issues, and we will need to further investigate.

Hope this helps. Thanks!

Hello, Thanks for your reply. I got it working as a standalone app instead of using the examples given. It’s working well with the credentials that I have provided.

Hi vk.rahul318,

Glad to hear that it is working now. Happy Zooming! :slight_smile: