API error log debug

Hi,
We’ve got setup a website using the YoCoach online learning software.
It integrate with Zoom for 1 to 1 lessons.

I’ve gone through all the procedures to generate API keys and added them to the YoCoach platform.
I’ve got setup here on zoom a JWT app for this.

The integration is connected as the logs on zoom show the connection.
But no successful call is made for the enduser, and the error log is always the same.

We have a trial Zoom account which I’m told does have the necessary rights to create what we need.
I’ve tried logging into YoCoach with the same email address as the registered zoom account, and also logging into zoom app directly with the same.

Error as follows.

{

“endpoint”: “https://api.zoom.us/v2/users”,

“response_headers”: [

“Set-Cookie: zm_aid=”“; Domain=.zoom.us; Expires=Thu, 01-Jan-1970 00:00:10 GMT; Path=/; Secure; HttpOnly”

],

“date_time”: “2022-09-07 12:13:41”,

“method”: “POST”,

“request_body”: “{“action”:“custCreate”,“user_info”:{“type”:1,“email”:“EMAIL ADDRESS WAS HERE”,“first_name”:“TEST”,“last_name”:“TEACHER”}}”,

“response”: {

“code”: 2016,

“message”: “No permission, please contact Zoom customer support.”

},

“request_headers”: [

“accept: /”,

“authorization: ******”,

“connection: close”,

“content-type: application/json”

],

“request_params”: [

],

“http_status”: “400”

}

Can anyone help with the above?
I’ve exhausted all attempts at playing around with username and email address so it ties up with the YoCoach end.
The YoCoach end just asks for:

API Key
API Secret
JWT Token
Licence count.

@mark5,

Happy to help! Can you share the support documentation you are using to configure Zoom credentials in YoCoach ?

do you use a JWT Token or a SDK JWT Token

Hi, it’s the JWT.
Here’s the guide I followed for setup on YoCoach.

There’s not a lot to go wrong.
I set the Licence Count to 1, which it doesn’t actually mention in the guide here.

I’m a bit stuck with Zoom saying our account is fine, and YoCoach saying it should just work.

Any help appreciated!

then check, if you are using the correct version of creating the signature

JWT Signature (deprecated) → Milliseconds (const timestamp = new Date().getTime() - 30000)
SDK JWT Signature → Seconds (iat = Math.round((new Date().getTime() - 30000) / 1000))

this a common problem since june

Thank you for this, I’ve gone back to YoCoach, and hopefully this makes sense to them.

I chose JWT as their documentation suggested I use this, but can see now your mention of deprecation in 2023.
Are the fields generated on the SDK different?
At YoCoach, I have to input:

API Key
API Secret
JWT Token
Licence Count

Just to close this thread off, and for future people’s research.

It turns out that our account setup as a Trial despite being told would have the same privileges as a Pro or more, did not behave the same way.

Once we’d paid for a month of Pro and tried again, it all worked perfectly.

This thread below gave me enough direct info to go directly to Zoom support with, for them to concede it may have needed a purchased plan after all.

1 Like

This post was flagged by the community and is temporarily hidden.