APIs Approve Meeting Registration But Join URL Get Stuck On Waiting for Approval

Description
We have integrated Zoom Meeting APIs into our workflow. The meeting gets created using zoom API with manual approval mode. Our students (end users) join the meeting via our interface which registers the student via meeting registration API and immediately approves them using Approval API. We are then calling the select details API for meetings and opening the join URL received in the select details API.
At this point in time when we check in the zoom admin portal, the registration is shown already approved.
However, the student is asked to fill a form. Upon, filling the details in the form, the student is shown waiting for the approval screen even though the request is auto-approved. Please see relevant screenshots below.

Error
“Meeting Registration Pending Approval” on the join URL, even though the registration is already approved via API.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Which Endpoint/s?
CREATE MEETING - POST /users/{userId}/meetings
REGISTER USER - POST /meetings/{meetingId}/registrants
APPROVE USER - PUT /meetings/{meetingId}/registrants/status
GET JOIN URL GET /meetings/{meetingId}

SAMPLE JOIN URL -

How To Reproduce (If applicable)
Steps to reproduce the behavior:
It involves logging into our paid portal so we will not be able to share credentials over a public forum.

Screenshots (If applicable)

Additional context
Response Logs created by our applications for the above case are as follows (with personal information masked):
{‘uuid’: ‘q/ZdBkK7Ryel2mvGF5d5kg==’, ‘id’: 91325867750, ‘host_id’: ‘3GCLjxf6QbeyYsLULyFEPw’, ‘host_email’: ‘XXXXXXXX@XXXXXX.com’, ‘topic’: ‘testing class please Meeting7’, ‘type’: 2, ‘status’: ‘waiting’, ‘start_time’: ‘2020-12-22T20:05:00Z’, ‘duration’: 15, ‘timezone’: ‘Asia/Calcutta’, ‘created_at’: ‘2020-12-22T20:01:07Z’, ‘start_url’: ‘https://imsindia.zoom.us/s/91325867750?zak=eyJ6bV9za20iOiJ6bV9vMm0iLCJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiIzR0NManhmNlFiZXlZc0xVTHlGRVB3IiwiaXNzIjoid2ViIiwic3R5IjoxMDAsIndjZCI6ImF3MSIsImNsdCI6MCwic3RrIjoidnV4WndSXzJyQXViUzJObHZqekVsZVd1VW84azl4eTg0bWJhSVJmaTl3TS5CZ1lzTkN0VGNWTXhWVWQ1TlVsSlJHTTBabEE0V1VoT2NrNWhPVnBJVlZsbWF6RmFWVEkzYlUxRWRDdFFiejFBTTJOa09UTmxNVFEyT1dSbU1qQTJNMkkzTldVM1pUaGxZbUUyWmpWa09ETTJPRGd6TlRCaVltVTRZakJsT0daaU5qVTBaRFZpTldVMlpEUXdZemxtWmdBZ2QwY3hhalJTTUhKVWRYVlRjaXMwYUc5WmNtcHNZbFZ0YldsVmRGQndNR2tBQTJGM01RQUFBWGFNQ29MNkFCSjFBQUFBIiwiZXhwIjoxNjA4Njc0NDY3LCJpYXQiOjE2MDg2NjcyNjcsImFpZCI6IjN1U2E5SEtxVFJpY2hoQWFsUTAyMkEiLCJjaWQiOiIifQ.V5cZuW25c2f_ltkh07LOV3Yb0qzLM4aVHLIlN1jqoV0’, ‘join_url’: ‘https://imsindia.zoom.us/j/91325867750?pwd=SFREdFB2UlFMTFg2L0J6a2J6R1ZsZz09’, ‘registration_url’: ‘https://imsindia.zoom.us/meeting/register/tJUudeygqDwtH9Qzu8SW-n9bkXTB09vzngpC’, ‘password’: ‘053137’, ‘h323_password’: ‘053137’, ‘pstn_password’: ‘053137’, ‘encrypted_password’: ‘SFREdFB2UlFMTFg2L0J6a2J6R1ZsZz09’, ‘settings’: {‘host_video’: False, ‘participant_video’: False, ‘cn_meeting’: False, ‘in_meeting’: False, ‘join_before_host’: False, ‘jbh_time’: 0, ‘mute_upon_entry’: False, ‘watermark’: False, ‘use_pmi’: False, ‘approval_type’: 1, ‘audio’: ‘both’, ‘auto_recording’: ‘cloud’, ‘enforce_login’: False, ‘enforce_login_domains’: ‘’, ‘alternative_hosts’: ‘’, ‘close_registration’: True, ‘show_share_button’: False, ‘allow_multiple_devices’: False, ‘registrants_confirmation_email’: True, ‘waiting_room’: False, ‘request_permission_to_unmute_participants’: False, ‘global_dial_in_countries’: [‘US’], ‘global_dial_in_numbers’: [{‘country_name’: ‘US’, ‘number’: ‘+1 3126266799’, ‘type’: ‘toll’, ‘country’: ‘US’}, {‘country_name’: ‘US’, ‘number’: ‘+1 6465588656’, ‘type’: ‘toll’, ‘country’: ‘US’}, {‘country_name’: ‘US’, ‘number’: ‘+1 3017158592’, ‘type’: ‘toll’, ‘country’: ‘US’}, {‘country_name’: ‘US’, ‘number’: ‘+1 3462487799’, ‘type’: ‘toll’, ‘country’: ‘US’}, {‘country_name’: ‘US’, ‘number’: ‘+1 6699009128’, ‘type’: ‘toll’, ‘country’: ‘US’}, {‘country_name’: ‘US’, ‘number’: ‘+1 2532158782’, ‘type’: ‘toll’, ‘country’: ‘US’}], ‘contact_name’: ‘XXXXXX XXXXX’, ‘contact_email’: ‘XXXXXXX@XXXX.com’, ‘registrants_email_notification’: False, ‘meeting_authentication’: False, ‘encryption_type’: ‘enhanced_encryption’, ‘approved_or_denied_countries_or_regions’: {‘enable’: False}}}

{‘success’: True, ‘joinUrl’: ‘https://imsindia.zoom.us/j/91325867750?pwd=SFREdFB2UlFMTFg2L0J6a2J6R1ZsZz09’, ‘registrantId’: ‘5B9S7icMTJOKKh_F9UijoQ’, ‘message’: ‘registrant added Successfully’}

{‘success’: True, ‘message’: ‘Approval Done’, ‘code’: 204}
[2020-12-23 01:32:46,554] INFO from Ims_Live_APIs: {‘message’: ‘Registrant approved’, ‘success’: True, ‘joinURL’: ‘https://imsindia.zoom.us/j/91325867750?pwd=SFREdFB2UlFMTFg2L0J6a2J6R1ZsZz09’, ‘email’: ‘XXXXXXXX@XXXXXX.com’, ‘variantName’: ‘XXXXXXXXXXXX’, ‘classTitle’: ‘testing class please Meeting7’, ‘classDate’: datetime.datetime(2020, 12, 23, 1, 35), ‘registrantId’: ‘5B9S7icMTJOKKh_F9UijoQ’}

Hey @gourav.ims,

Thank you for reaching out to the Zoom Developer Forum. When you make a request to the Add Meeting Registrant API are you setting the auto_approve value there or is this set in the Zoom UI?

Thanks,
Max