Attendee unable to send a message to panelists

Description
Attendee cannot send a message to panelists via browser client. Even though the “Allow participants to chat:” select value is set to “All panelists”, messages cannot be read by panelists. If you change it to the “All panelists and attendees” it works but it should work the other way around too.

Error
There isn’t any error message for this.

Which version?
Current browser client of Zoom

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Start the session, host use Zoom app for Mac OS to host the session
  2. Attendee join the session via web browser (Google Chrome)
  3. Host and attendee send messages, no issue.
  4. Host restrict attendee to chat with All panelists (see screenshot 1)
  5. Attendee can send the messages and it seems like the chat went through
  6. Host unable to see the messages This issue doesn’t happen when the attendee is using Zoom app for Mac
  7. Host switch back to chat with Everyone publicly
  8. Attendee send the message, host can see

Screenshots
screenshot1

Device:

  • Device: MacBook Pro (13-inch, 2015)
  • OS: macOS Mojave 10.14.6
  • Mac Zoom Client Version : 4.6.7 (18176.0301)
  • Browser: Chrome
  • Browser Version: 80.0.3987.132 (Official Build) (64-bit)

Hey @bykurs1, thanks for posting and using Zoom!

Please let me know if this thread solves the issue for you:

Thanks,
Tommy

Hey Tommy, thanks for quick response. Unfortunately it doesn’t solve the problem.

Hey @bykurs1,

Are the panelists able to see the messages from the attendees? Or are both host and panelists not able to see the messages?

Thanks,
Tommy

I’ve just tried with one panelist, one host and an attendee. I couldn’t see what attendee send as a panelist and host.

Same here. I think it doesn’t update chat state properly. Our company has urgency due to Covid-19. So a hot fix would be awesome.

Hey @bykurs1, @xnart,

If you aren’t using the Zoom SDK please reach out to support.zoom.us for assistance.

Also make sure that the allow in meeting chat is turned on:

Thanks,
Tommy

Hello again, im using Zoom SDK, my students join the webinar via browser. I don’t get it. Does the browser not use the Zoom SDK anyway?

Thanks.

Hey @bykurs1,

The Zoom Web Client and Zoom Web SDK are a little different.

Please make sure that the allow in meeting chat is turned on:

Thanks,
Tommy

Allow in meeting chat is turned on. The problem is when host restrict attendee to chat with All panelists, browser state doesn’t update. And it is still trying to send message to the “All panelists and attendees”. You can see the screenshots below.

Thanks

Hey @bykurs1,

Thanks for the screenshots. Can you provide the meeting ID so we can look into the issue further?

Thanks,
Tommy

Hello @tommy,

The webinar id is : 899232579

Another webinar i’ve just reproduce the bug : 327528749

Thanks.

Hi @bykurs1,

What version of the WebSDK are you using? I wasn’t able to reproduce it. I tried with the same steps and was able to see the chat when Host set it to All panelists.

  1. Attendee in the websdk types in a message(1st screenshot)
  2. Attendee in the websdk sends the message (2nd screenshot)
  3. Host receives messages(screenshot 3)

!

!

Do you have private chat enabled within your account settings?(see screenshot below)

Would you be able to provide your account ID if this issue is still present?

Hello @Michael_Purnell, thanks for reply.

Unfortunately, the problem persists. Chat and Private chat enabled.

What version of the WebSDK are you using?

I am using zoom web client. I use macOs client for hosting and my students join the webinar via browser. Nothing custom, just zoom web client.

My account no. is : 51918913

Thanks.

Hey @bykurs1,

Since the Zoom Web Client is not apart of the Zoom Developer Platform can you please reach out to support.zoom.us?

As a workaround, I suggest using the Zoom Desktop/Mobile App for this functionality and not the Zoom Web Client.

Thanks,
Tommy