Attendee unable to send a private message to host

Private chat doesn’t work.
We remember this function worked before (last year around September 2019, using v1.4.3 or v1.5.0 or v1.5.1). We don’t know when exactly this issue started to happen. We received this report from our customer as they’re suspecting that the host is not receiving their messages.

There isn’t any error message for this.

Which version?
Web SDK 1.7.0

To Reproduce
Steps to reproduce the behavior:

  1. Start the session, host use Zoom app for Mac OS to host the session
  2. Attendee join the session via web SDK v1.7.0 (Google Chrome)
  3. Host and attendee send messages, no issue.
  4. Host restrict attendee to chat with Host only (see screenshot 1)
  5. Attendee can send the messages and it seems like the chat went through (see screenshot 2)
  6. Host unable to see the private messages (see screenshot 3) This issue doesn’t happen when the attendee is using Zoom app for Mac
  7. Host switch back to chat with Everyone publicly
  8. Attendee send the message, host can see

Additional Notes

  1. To add more to point #5 above, the data captured in the “render” event (not sure if it’s just client side data or actually from the back-end) it shows that the chat is captured in the history hence showing the message in the client’s side. (see screenshot 5)
  2. During the “render event”, the data also show the correct participants and the user id (this triggered when host switch to host only, see step #4 above). Not sure if this is relevant at all, just pointing out that at this step the data should be correct. (see screenshot 4)
  3. From the data above, I could see the meeting settings show that there’s a flag called isPrivateChatEnabled set to false. Also unsure if this is relevant too. I couldn’t see any documentation regarding this. It’s also not in the Zoom’s init settings (see screenshot 6)

Screenshot 1
screenshot 1
(will try to add more screenshots in the reply as I’m restricted to upload just 1 image)


  • Device: MacBook Pro (15-inch, 2017)
  • OS: macOS Mojave 10.14.6
  • Version: 80.0.3987.122 (Official Build) (64-bit)
  • Browser: Chrome

Screenshot 2

Screenshot 3

Screenshot 4

Screenshot 5

Screenshot 6
screenshot 6

Hey @mini.cactus, thanks for posting and using Zoom!

I appreciate the detailed post, and have notified our team of this issue. (ZOOM-141683)

We will investigate and get back to you as soon as possible.


Hey @mini.cactus,

We just released private chat in version 1.7.2.

Please update to the latest version.


Hi @tommy,

Thank you for the follow-up!
I’ve updated the Web SDK to the latest version (1.7.2) and made sure I’m using the latest version of the client app for Mac ( but unfortunately the problem persists :frowning:


Hey @mini.cactus,

I was unable to reproduce the issue, however I am using the Mac Zoom App. The host can see my private message.

Did I miss a step?


Hi @tommy, thank you for your prompt reply!

Hmmm that’s weird.
I test with Mac Zoom App too.
I tried with different configurations but still couldn’t figure out the reason of this issue is happening right now on our end. Is there a simple way to do this?

  • I suspected that the name containing emoji caused the issue, tried renaming without emoji but the problem persists
  • Tried enabling video (to ensure that I’m following the same configuration/condition as your screenshot as much as possible), the problem persists unfortunately
  • One thing I noticed that the recipient name is somehow buggy (Everyone recipient is not hidden/removed when switching to private chat only, see screenshot-1), I thought it was just a small bug that happens to everyone but your screenshot suggest otherwise (but probably has nothing to do with this bug we’re experiencing)
  • Mac Zoom App: Version: 4.6.7 (18176.0301)
  • Mac Chrome App: Version 80.0.3987.132 (Official Build) (64-bit)

Could you also help to check if there’s anything odd from our configurations?

  1. Downloaded all the assets from Zoom’s CDN and host it on our cloud server: (added spacing due to 2-links restriction)
    https:// source. zoom. us/1.7.2/lib/vendor/react.min.js
    https:// source. zoom. us/1.7.2/lib/vendor/react-dom.min.js
    https:// source. zoom. us/1.7.2/lib/vendor/redux.min.js
    https:// source. zoom. us/1.7.2/lib/vendor/redux-thunk.min.js
    https:// source. zoom. us/1.7.2/lib/vendor/jquery.min.js
    https:// source. zoom. us/1.7.2/lib/vendor/lodash.min.js
    https:// source. zoom. us/zoom-meeting-1.7.2.min.js
  2. Meeting settings I used to test to replicate this issue (Screenshot-2)
  3. Our Web SDK Configuration script (Screenshot-3)



Hey @JackYang can you take a look at this?


Hi @JackYang, Thank you for your help with the chat lagginess issue last time.

Not sure if this has anything to do with our account type, but ours is this:

I’ll PM you our account ID too, in case you need it.


Thanks for providing this info @mini.cactus we will take a look. (CS-1550)


We just signed up to zoom yesterday, and having the exact same problem. Need this feature for a meeting on Tuesday and can’t get through to support. Very frustrating.

When the chat options are set to “Participant can chat with everyone”, the host sees all messages fine. When the option is set to “Participant can chat with host only”, any chat sent by attendee does not get seen by the host or anyone else.

Using the desktop client Version: 4.6.7 (18176.0301) on windows 10.

Hey @zoomcrockers,

Are you using the Web SDK?


I don’t know the answer to that sorry. As the hoster we are using the Zoom desktop app for Windows.

And the attendee is clicking the “Join in a browser” and joining the meeting in the web browser

Screenshot-3 re-upload (removed some details)

Hi @mini.cactus,

I wasn’t able to reproduce the error. I just downloaded the sample web app and only included the API keys to get it started. The host was using a Mac with the latest Zoom client.

Do you have private chat set within the Account settings?

1 Like