Attendees_can_comment returning false

As I create a webinar via API, I’m trying to enable attendees comment for webinar Q&A but the response is returning “false” although I’m passing “true” for “attendees_can_comment”.

All the other settings seems to be OK.

Isn’t this some kind of bug?

Hi @philipp
Thanks for reaching out to the Zoom Developer Forum!
Could you please share with me the request body that you are passing so I can try and replicate this issue further?

Hi @elisa.zoom .
Thanks for your reply.

The request body that I’m passing is below:

$webinar = new Webinar();
$data = [
  'topic' => "My Webinar",
  'type' => 5,
  'agenda' => "Here is my webinar!",
  'start_time' => date('n月j日') ."T20:00:00",
  'settings' => [
    'host_video' => true,
    'panelists_video' => true,
    'practice_session' => true,
    'hd_video' => true,
    'approval_type' => 0,
    'audio' => 'voip',
    'auto_recording' => 'local',
    'close_registration' => true,
    'show_share_button' => true,
    'question_and_answer' => [
      'attendees_can_comment' => true,
$webinar = $webinar->create($data);

Hope you can find something.
Thank you.

Hi @philipp
Thanks for sharing this with me.
I was able to do some debugging on my end and it looks like if you pass the field “answer_questions” with the value “all” in your question_and_asnwer object, along with the “attendees_can_comment” set to true, then it will respect the value.

Let me know if this does the trick for you:

    "topic" : "My test",
    "type" : 5,
    "agenda" : "Here is my webinar",
    "start_time" : "2022-11-01T00:00:00Z",
    "settings" : {
        "host_video": true, 
        "panelists_video" : true,
        "hd_video": true, 
        "approval_type" :0,
        "audio": "voip",
        "auto_recording" : "local",
        "close_registration" : true, 
        "show_share_button" : true, 
        "question_and_answer" : {
            "answer_questions" : "all",
            "attendees_can_comment": true

Hi @elisa.zoom ,
Thank you it worked!!!

However, I think the code I showed you used to be working at least several months ago.
Has the specification of the API changed within these several months?

Hi @philipp
Happy to hear that worked!
Interesting! I am not aware of any specific change on our API that could have caused this.
I apologize for the inconvenience and let me know if there is anything else i could do for you