AudioType is being switched to NONE on its own

Is there any reason why the AudioType would automatically switch from VOIP to NONE after joining a call? I’m using custom ui. Also, when I uninstall the application and build it again, the audio works fine the first time. It asks me to confirm if i want to give access to camera and microphone. Its when I run it a second time or after that there is no audio. There is still video however.

Using the latest version of the SDK, just downloaded it on Monday.

Smartphone (please complete the following information):

  • Device: iPhone 7
  • OS: iOS 12.3

Hi oderza,

Thanks for using Zoom SDK. Do you mean that even if you select VoIP after joining the meeting, then it will automatically switch to None? Could you provide more detail on how to reproduce this?

For custom UI, the idle/default status for AudioType is None after start/join a meeting, if you would like to join as VoIP, you can use the following interface before the meeting:

Or use the following interface while in the meeting:


I started deploying and testing on my iPad and the issue no longer happens. I will try again to see if it is still happening on my iPhone 7 and report back with iOS version.

Glad to hear that the issue no longer happens. Let me know if you have any other questions. Thank you!

I was able to reproduce this scenario using the sample application on iOS as well as my own application. I have the settings in the zoom supplied iOS sample app as :
[[[MobileRTC sharedRTC] getMeetingSettings] setAutoConnectInternetAudio:YES]
[[MobileRTC sharedRTC] getMeetingSettings].enableCustomMeeting = YES
via settings

Usually the first time I run the app connecting to the desktop application hosting the meeting, it works as expected, audio connects and works. After disconnecting and reconnecting to a meeting again I’ve seen the audio type switch from VOIP to None via the onSinkMeetingAudioStatusChange in CustomMeetingViewController+MeetingDelegate.m which in turn calls BottomPanelView:updateMyAudioStatus where reading the audioType via [ms myAudioType] returns MobileRTCAudioType_None and sets the icon for the audio button to ‘icon_meeting_noaudio’. Tapping the button will then prompt for the type of Audio connection and connect correctly upon choosing the type. I was expecting this to not change.

You can also watch the ‘microphone’ icon disappear for the newly connected user in the Zoom desktop application if you have the ‘Manage Participants’ side panel open. The new user will appear with the microphone icon and video icon visible, but when this issue happens the microphone icon will disappear very quickly after you see the user appear (this is when you get the audio status change in the iOS SDK sample app).

Hi schalky,

Thanks for using Zoom SDK and thanks for the detailed information. I tried to reproduce the issue with the steps you were describing with our demo app and I am not able to see the same situation as you are mentioning. May I inquire which version of SDK are you using?

Here are the steps that I tried:

  1. Set auto connecting VoIP using [[[MobileRTC sharedRTC] getMeetingSettings] setAutoConnectInternetAudio:YES];
  2. Enable custom UI using [[MobileRTC sharedRTC] getMeetingSettings].enableCustomMeeting = YES;
  3. Add a NSLog to print out the audio type in: by calling MobileRTCAudioType type = [[MobileRTC sharedRTC] getMeetingService].myAudioType;
  4. Build the app and join a meeting that is started by the Zoom desktop client
  5. Upon successfully joined the meeting, the myAudioType returns 0, which means the audio is VoIP. When you press the mute/unmute button, the audio type is still 0; If you press “More” and then press “Disconnect Audio”, then the audio type becomes 2, which is None.

You can also have a look at the here:, the icon shown is depending on the audio type. If the audio type is none, then the icon won’t show correctly.

One assumption would be your audio device has some problems, if you are still getting this scenario, could you send us your .crash log and SDK log?

Hope this helps. Thanks!