Automatic Cloud Recording not working

I have an issue where the auto record in my meeting is suddenly unusable,
the case, I created a meeting link using the create meeting API, and when I started the meeting, the automatic record did not work
but when I create a meeting using the desktop zoom application, the meeting can record automatically

can you help me, what is the cause? this happened suddenly, for before it could run smoothly

Hi @islamiccyb.erdentist
Thanks for reaching out to the Zoom Developer forum and welcome to our community!
Could you please share with me the entire request body that you are sending when creating the meeting so I can take a look at your request and try to replicate this issue on my end?

like this
exports.createMeetings = async params => {
const { userId, topic, duration, agenda, roomType } = params;
const token = await jwtZoom();
const url = ${process.env.ZOOM_API_URL}users/${userId}/meetings;
const payload = {
topic: topic || ‘Islamic Cyber Dentistry’,
type: 1,
duration: duration || 120,
timezone: ‘Asia/Jakarta’,
password: ‘xxxx’,
agenda: agenda || ‘Islamic Cyber Dentistry’,
settings: payloadSettings,
roomType: roomType || ‘Islamic Cyber Dentistry’,
// console.log({ token, url, payload });
const response = await, payload, {
headers: {
‘Content-Type’: ‘application/json’,
Authorization: Bearer ${token},
json: true,
if (!response) {
throw new Error(‘Cannot add meetings’);
if (response.status !== 201) {
throw new Error(‘Cannot add meetings’);

Hi @islamiccyb.erdentist
thanks for sharing this with me, but I noticed that you did not share the payloadSettings with me., it would be helpful if you can share that with me as well,

this is payloadSettings
const payloadSettings = {
host_video: true,
participant_video: true,
join_before_host: false,
mute_upon_entry: true,
watermark: false,
use_pmi: false,
approval_type: 0,
audio: ‘both’,
auto_recording: ‘cloud’,
enforce_login: false,
waiting_room: false,

Thanks, I will do some testing on my end and will come back to you

Hi @islamiccyb.erdentist
I did some testing on my end and it looks like you are setting the type of the meeting to be an instant meeting type 1 which uses the PMI of the host.
I would suggest you change the type of the meeting to type 2 to be a scheduled meeting and that way the autorecording_cloud will be applied.

Also, make sure to go to your Admin Tab > Account management > Account settings > Recording and enable the setting automatic recording to “record in the cloud”

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.