Create meeting with auto_recording setting does not appear to work?


#1

I am testing creating a meeting with “auto_recording” setting, and no matter what, on the response I get:

auto_recording: "none"

Example POST to: https://api.zoom.us/v2/users/{MY_USER_ID}/meetings

With this data:

{
	"topic": "Auto Recording Test 2",
	"type": 1,
	"settings": {
		"auto_recording": "cloud"
	}
}

And receive this response (Id’s and start_url redacted)

{
    "uuid": "XXXXXXXXX",
    "id": XXXXXXXXXXXX,
    "host_id": "XXXXXXXXX",
    "topic": "Auto Recording Test 2",
    "type": 1,
    "status": "waiting",
    "timezone": "America/New_York",
    "created_at": "2019-03-08T15:50:52Z",
    "start_url": "https://zoom.us/s/XXXXXXX/?blahblahblah",
    "join_url": "https://zoom.us/j/XXXXXXX",
    "settings": {
        "host_video": false,
        "participant_video": false,
        "cn_meeting": false,
        "in_meeting": false,
        "join_before_host": false,
        "mute_upon_entry": false,
        "watermark": false,
        "use_pmi": false,
        "approval_type": 2,
        "audio": "both",
        "auto_recording": "none",
        "enforce_login": false,
        "enforce_login_domains": "",
        "alternative_hosts": "",
        "close_registration": false,
        "registrants_confirmation_email": true,
        "waiting_room": false,
        "global_dial_in_countries": [
            "US"
        ]
    }
}

#2

Hi @Alex_Ciarlillo,

Can you make sure that automatic recording is set within your Zoom.us account?

Thanks


#3

It is disabled… but this is really confusing. If I turn it on, does it automatically do this for every meeting? So that if I want to create a meeting via the API, I need to set ‘auto_recording’ to ‘none’?


#4

Yeah I just tested this… and now I have the opposite problem. If I enabled “auto recording” at the accout level, every meeting I create has it enabled, and the API create call does not accept a setting to disabled it.

I tried POSTing with:

{
	"topic": "Auto Recording Test 3",
	"type": 1,
	"settings": {
		"auto_recording": "none"
	}
}

And the meeting still comes back as being auto-recorded to the cloud, and does indeed start recording on launch.


#5

Hi @Alex_Ciarlillo - have you tried doing a scheduled meeting (type: 2)? I’m wondering if the instant meetings behave differently.


#6

With “auto recording” ON in account settings:

POST

{
	"topic": "Auto Recording Test 4",
	"type": 2,
	"start_at": "2019-03-14T14:00:00Z",
	"settings": {
		"auto_recording": "none"
	}
}

Response:

{
   ...redacted fields ....
    "settings": {
        "host_video": false,
        "participant_video": false,
        "cn_meeting": false,
        "in_meeting": false,
        "join_before_host": false,
        "mute_upon_entry": false,
        "watermark": false,
        "use_pmi": false,
        "approval_type": 2,
        "audio": "both",
        "auto_recording": "cloud",
        "enforce_login": false,
        "enforce_login_domains": "",
        "alternative_hosts": "",
        "close_registration": false,
        "registrants_confirmation_email": true,
        "waiting_room": false,
        "global_dial_in_countries": [
            "US"
        ]
    }
}

With “auto recording” OFF on account settings:

POST

{
	"topic": "Auto Recording Test 4",
	"type": 2,
	"start_at": "2019-03-14T14:00:00Z",
	"settings": {
		"auto_recording": "cloud"
	}
}

Response:

{
   ...redacted fields....
    "settings": {
        "host_video": false,
        "participant_video": false,
        "cn_meeting": false,
        "in_meeting": false,
        "join_before_host": false,
        "mute_upon_entry": false,
        "watermark": false,
        "use_pmi": false,
        "approval_type": 2,
        "audio": "both",
        "auto_recording": "none",
        "enforce_login": false,
        "enforce_login_domains": "",
        "alternative_hosts": "",
        "close_registration": false,
        "registrants_confirmation_email": true,
        "waiting_room": false,
        "global_dial_in_countries": [
            "US"
        ]
    }
}

It really just looks like this flat out does not work as documented.


#7

Hi @Alex_Ciarlillo,

Within the Zoom Portal, under Account Settings, can you make sure the lock button is disabled and try again?


#8

That seems like it did the trick. Thank you!