Call recording - No recording privilege


#1

I’m trying to test out call recording, but I seem to never have recording privilege. I’ve tried a bunch of different things but can’t get it working. For reference, this is on Beta 16 on Windows 10.

I’ve tried scheduling a meeting through both the zCommand Schedule Add command and my own zoom account. When I joined either with the Zoom Room, I get host status, but both can_record of the Participant and canRecord of the UpdateCallRecordInfo are false. Trying to record at this point gave me the “no privilege” error. I then tried to run the zCommand Call AllowRecord command to give myself recording privilege. This updated the can_record of the Participant to true, but the other remained false. Again, trying to record gave me a “no privilege” error.

If I joined the Zoom Room in that meeting, I easily had the Zoom Room give my account recording privilege with the AllowRecord command and I was able to record, but the Zoom Room still couldn’t.

I’ve tried messing with the web settings – all three recording toggles are turned on. Please help. What’s my mistake, or is this a bug?


#2

Hello Jeffrey, have you tried using an iPad ZRC controller and seeing if you can record from there?

For recording, there are two things you need:

  1. Recording privilege
  2. Email address for cloud recording (Zoom Room cannot record locally)

For recording privilege:
Please use an iPad ZRC and see if you can record from there.
Also, the host must have a pro account. Is the account associated with your Zoom Room a pro account?

For Email:
For Meetings scheduled using zCommand Schedule Add, and instant meetings, they don’t have an email associated with them so the user must manually give an email address, however right now we do not support this feature on ZAAPI so for meetings that require the user to give an email you cannot record and will get error message “Need email address”

For meetings scheduled using Google calendar or other calendar apps, there is an email associated with them so the user does not need to manually enter an email to record, those should work as long as you have recording privilege.

When you give recording privilege to a participant, it allows the participant to record locally (not to the cloud) so email is not required.