Can not start Video, audio or other features from UI

Description
When clicking join from UI (video, audio or other features card), a new tab opens in the browser. But, it keeps saying “waiting to join meeting”. Found in the network console that meeting password is incorrect. But, is it required to have password? If yes, from where would I get it?

Error
Saw the network tab and found the following response for one endpoint.(https://zoom.us/wc/lsdk).

__jsonp_callback__1({“status”:false,“errorCode”:3000,“errorMessage”:“Meeting password is incorrect”})

Which version?
Fully Customizable SDK

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Start the fully customizable SDK
  2. Go to browser and select join from video, audio or other features(screen share, chat) card
  3. New tab opens and keeps showing ““waiting to join meeting””. But, it should open the relevant feature.

Screenshots

Device (please complete the following information):

  • OS: Ubuntu
  • Version: 18.04
  • Browser: Chrome / Mozilla Firefox

Thank you so much for sharing (https://zoom.us/wc/lsdk)

Hey @ahmed.shafath ,

Are you using the Fully Customizable SDK sample app? The error you are receiving makes me think you are using the Client SDK.

@limmediaunlimited , are you also needing help?

Thanks,
Tommy

I get the same error using the sample app for fully customizable web sdk.

Hey @Amar ,

Can you please share steps to reproduce the issue and what device and browser you are using?

Thanks,
Tommy

This is happening to me as well except I dont see any error. I was led here because calling client.join with a valid signature hangs indefinitely (the promise never resolves or rejects with no errors in the console).

I followed the steps in the /zoom-instant-sdk-web-1.0.0/README.md file which I downloaded from https://marketplace.zoom.us/develop/apps/<my app id>/download

UPDATE: I confirmed the same behavior is happening in the sample app as is in my own application.

I saved the client.join promise to a global variable and see that the promise never resolves:

In /zoom-instant-sdk-web-1.0.0/Sample&Libs/features/join.js:

window.clientJoinPromise = client
      .join(
        instantArgs.topic,
        instantArgs.token,
        instantArgs.username,
        instantArgs.password
      )
      ...

Yes, I also had the same problem with the Fully Customizable SDK. Eventually, I managed to run the demo when I played a little bit with different combinations for the password and the session name. Some combinations work, but I haven’t found a specific pattern. This is very odd behavior.

Here is one example of a combined session name + password that worked for me:

1 Like

Hey @ondrej.palkoci , @jamis0n ,

Thanks for reporting this issue. Our engineers are looking into this now. (CS-2915)

-Tommy

Hey @limmediaunlimited , @jamis0n , @ondrej.palkoci , @Amar , @ahmed.shafath ,

Can I ask how many characters your passcodes for the video session are? There is currently a 10 character limit that could be causing this issue.

Thanks,
Tommy

Hey @tommy,

I have the same issue running the sample app that came with the sdk as well as in a sample react app. The client.join promise never resolves, I tried various combinations of topic/username/passwords.

Browser is chrome latest version on macOS Big Sur.

@tommy I tried 2,4,8 characters but same issue.

@tommy - In my brief exploration, I’ve noticed that blank/empty passwords dont work, but if you try to join a session initially like that, you cant “change” the password.

If you choose a brand new topic name and a password like password1, it joins successfully.

Are there any guidelines about how the password functionality works? It appears to be set on the very first join and then cant be changed after that.

Is there an admin API to change it server side somehow?

@tommy - Let me describe my findings after my initial question -

If we type the username and topic but leave the password blank, we get the error with errorcode 3000 while joining video or any feature. Remember, password field is not mandatory for new session.
But, it looks like the session gets created in this case. Next time, when you try to join with the same username and topic, we get the “Meeting password incorrect” error.

In general, filling username, topic and password uniquely work fine in creating sessions. It would be good to see the session details that zoom is creating behine the scene. Is there any way to view/monitor the sessions that zoom is creating?

Hey @ahmed.shafath , @jamis0n , @Amar ,

Thank you for sharing your findings, we are looking further into this issue and will get back to you as soon as possible.

-Tommy

Hey @ahmed.shafath , @jamis0n , @Amar ,

Can you please try upgrading the version you are using? It looks like this could have been a bug and we have since fixed it. :slight_smile:

There are no guidelines besides the 10-character limit

No.

Not currently.

Thanks,
Tommy

@tommy Thanks! that worked.

1 Like

Happy to hear that @Amar , please let us know if we can help with anything else! :slight_smile:

Thanks,
Tommy

Hi @tommy

How to upgrade the version of the fully customizable SDK? In my zoom account, I can still see the old versions of the fully customizable SDKs (for web instant SDK it’s 1.0.0).

I can see there have been many updates in the api documentation (@zoomus/instantsdk). But, I am unable to access the updated api’s from the version I am using.

Hey @ahmed.shafath ,

Great question, you should be able to download the latest version of the SDK from your marketplace app at the moment. :slight_smile:

Let me know if that helps!

Thanks,
Tommy