Cannot Upgrade SDK

Description

We have using react version 16.13.1, zoom sdk requires 16.8.6 thus cannot upgrade it from 16.9.0.

Error

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: project-name@1.0.0
npm ERR! Found: react@16.14.0
npm ERR! node_modules/react
npm ERR!   react@"^16.13.1" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer react@"16.8.6" from @zoomus/websdk@1.9.1
npm ERR! node_modules/@zoomus/websdk
npm ERR!   @zoomus/websdk@"^1.9.1" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 

Which Client Web SDK version?
Knowing the version can help us to identify your issue faster. [e.g. 1.9.0]

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Upgrade zoom sdk to latest version.

Additional context
N/A

Update: Project using react > 16.8.5 cannot upgrade from zoom 9.0.

Hey ankur.sharma,

Thank you for reaching out to the Zoom Developer Forum. It looks like your project has react at version ^16.13.1 as a dependency in your package.json file. I would change the react version in your package.json file to “16.8.6” so that you are using a version of react that is compatible with the Web SDK.

After you change the version in your package.json file, remove the node_modules folder and reinstall dependencies.

Let me know if that helps.

Thanks,
Max

That didn’t help, series of dependencies error.

Using latest react on websdk would greatly help.

Have your issue solved?

I have same issue, please help if possible

Hey @ankur.sharma and @akshayareddy22111,

Thank you for the update. I can understand that using the latest version of react can be helpful but this isn’t something we can continually deliver due to our engineering teams testing process.

However, this issue is related to the dependencies used by your project and you should be able to resolve the issue by removing or changing the dependencies used in your package.json file.

You can see in our Sample Vue.js App that we don’t include react as a dependency either.

If you’re able to provide the package.json file you’re using, I can be more specific on the changes that need to be made. Also, the new dependency errors that you’re seeing can help to troubleshoot the issue.

Thanks,
Max

These are the associated dependencies:

"@zoomus/websdk": "^1.9.0",
"bootstrap": "^4.5.0",
"connected-react-router": "6.4.0",
"history": "^4.9.0",
"i18next": "^19.8.4",
"prop-types": "15.7.2",
"react": "^16.13.1",
"react-bootstrap": "^1.0.1",
"react-bottom-scroll-listener": "^4.1.0",
"react-calendar-heatmap": "^1.8.0",
"react-circular-progressbar": "^2.0.1",
"react-color": "^2.19.3",
"react-datepicker": "^3.1.3",
"react-device-detect": "^1.6.2",
"react-dom": "^16.13.1",
"react-dropdown-tree-select": "^2.3.1",
"react-full-screen": "^0.2.4",
"react-ga": "^2.5.7",
"react-google-recaptcha": "^1.0.5",
"react-helmet": "5.2.1",
"react-highlight-words": "^0.16.0",
"react-html-parser": "^2.0.2",
"react-i18next": "^11.8.5",
"react-input-mask": "^3.0.0-alpha.2",
"react-intl": "2.8.0",
"react-lazyload": "^3.0.0",
"react-pdf": "^4.1.0",
"react-redux": "7.0.3",
"react-router-dom": "5.0.0",
"react-router-redux": "^4.0.8",
"react-select": "2.4.3",
"react-slick": "^0.24.0",
"react-smartbanner": "5.1.3",
"react-sortable-hoc": "^1.11.0",
"react-stripe-checkout": "2.6.3",
"react-stripe-elements": "^3.0.0",
"react-tooltip": "^3.10.0",
"redux": "4.0.1",
"redux-saga": "1.0.2"

Hey @ankur.sharma,

Thank you for sharing your project dependencies! It looks like you were getting dependency errors because in order to use an older version of the react package, you’ll also want to make sure your other dependencies (react-*) are compatible with the older react package.

Let me know if that helps.

Thanks,
Max