Can't start meeting, MEETING_STATUS_FAILED

Hello, I encountered some problems when using ‘zoom-electron-sdk’ development, failed to start the meeting.

Description

Set the domain and enter the key and secret, then select “join withoutLogin”, enter the parameters of the conference created by API (JWT), and then click “start” to start the meeting. The data printed by the console is as follows:


hasRawDataLicense 6
meetingstatus 1 0
StartMeetingWithOutLogin 0
meetingstatus 6 0
meetingstatus 4 0
meetingstatus 7 0

First I want to know what does ‘hasRawDataLicense 6’ mean.

Then, I want to know what does ‘meetingstatus 6 0’ mean, is it caused by network reasons or abnormal parameters?

Status code:

MEETING_STATUS_IDLE: 0, // Idle status, no meeting running
MEETING_STATUS_CONNECTING: 1, // Connecting meeting server status
MEETING_STATUS_WAITINGFORHOST: 2, // Waiting for host to start meeting
MEETING_STATUS_INMEETING: 3, // Meeting is ready, in meeting status
MEETING_STATUS_DISCONNECTING: 4, // Disconnecting meeting server status
MEETING_STATUS_RECONNECTING: 5, // Reconnecting meeting server status
MEETING_STATUS_FAILED: 6, // Meeting connection error
MEETING_STATUS_ENDED: 7, // Meeting is ended

Which version?

v4.6.15798.0403

hi
You used start meeting without login,please make sure the params is right.

startunlogin: function(meetingnum){
var opt = {
meetingnum: ‘xxxx’ , //the valid meeting number
userid:‘xxx’,//user id, you can get via REST API or start uri.
usertoken:‘xxyyzz’,//user token, you can get via REST API or start uri.
zoomaccesstoken:’’,//ZAK(zoom access token)
username:‘abc’ //username in meeting
}
let ret = zoommeeting.StartMeetingWithOutLogin(opt);
console.log(‘StartMeetingWithOutLogin’, ret);
},

1 Like

Thank you for your reply.

Is ‘meetingnum’ necessary? I looked at the SDK demo source code, this parameter is not needed.

This is my parameter value, it should be correct:

Actually, I want to know what the “hasRawDataLicense 6, MEETING_STATUS_FAILED: 6, // Meeting connection error” error means.

The account I use is pro level.

The problem is solved, the “meetingnum” parameter is indeed required, but the official demo does not, embarrassing😭

Anyway, thank you!!!

Hi hejx,

Thanks for the reply. Glad to hear that it is working. Happy Zooming!