Config took longer than 10000ms to respond on macos sonoma 14.3

Zoom App, React, Node, Firebase

When calling configureZoomSdk(), I’m getting: “config took longer than 10000ms to respond” when testing from macos Sonoma (14.3 (23D56)). I’m testing on a macbook pro max m3. I run Windows 11 (in parallels) and everything runs fine. I have also tested on a Dell laptop and no issues. I’m guessing it’s the ‘webkit’ in macos/safari or perhaps a security setting that I am not aware of?

“config took longer than 10000ms to respond”

Troubleshooting Routes
I have tried to reduce scopes just to “getRunningContext” within configureSdk() and still have same issue.

How To Reproduce
I am able to consistently reproduce on every load.


useEffect(() => {
console.debug(‘configureSdk fired’)

	const configureSdk = async () => {

		try {

			const configResponse = await zoomSdk.config(
					capabilities: [
						// 'getMeetingUUID',
						// "getSupportedjsApis",
						// "getMeetingContext",
						// "getMeetingParticipants",
						// "getMeetingJoinUrl",
						// "getAppContext",

						// "onParticipantChange",
						// "onRunningContextChange",

						// in-client api and event
						// "authorize",
						// "onAuthorized",
						// "getUserContext"


			console.debug('Zoom JS SDK Configuration', configResponse)
		catch (e) {

		.then(() => {
			console.debug("zoom sdk configured")
		.catch((error) => console.error('Zoom SDK Configuration', error))

}, [zoomSdk, setRunningContext, setUserContext, setSdkConfigured])

return { runningContext, userContext, sdkConfigured }


This runs in a useConfigureZoomSdk react hook.

I found my issue. I had a script tag in my index.html referencing the as well as an import zoom/appssdk statement. I had forgot that I had added the script tag some time ago. oops!

index.html: script src=“
ZoomContext.jsx: import zoomSdk from ‘@zoom/appssdk’

don’t load both!