Connection failed: Invalid access token

Hello

We succeed to create the JWT app

But we can’t connect to it from moodle

We get all the time the error: Connection status: Connection failed: Invalid access token.

Hi @barhum77 - we will investigate, but I wanted to note I’ve edited your post to remove sensitive information about your account.

@barhum77 have you used the Zoom LTI Pro Moodle integration?

Hello Michael,

Can you please do a hard reset to my account too?
120788035
I deactivated and activated many times but still doesn’t work.

Thank you
Yan

Hey @australianewtalents,

We are working on it. :slight_smile:

Thanks for your patience,
Tommy

“Connection failed: Invalid access token.”
Hi, i cannot connect to zoom from Moodle, my plugin does not function.
What can i do?

1 Like

Hey @damian,

Can you please share a screenshot of the issue and steps to reproduce?

Thanks,
Tommy

Hi Tommy,
thanks for the replay.
I have integrated Zoom in Moodle through the Zoom-Plugin. In Moodle I must set up this plugin, and the problem is that I have no connection from my Moodle to Zoom, the token cannot establish connection.
Please see the attachment.
What can I do to bring the token in function, I dont no where the token is and where the failure is.
Thanks for your support.
Dan

Hey @damian,

Please try regenerating your JWT Secret.

Thanks,
Tommy

I do that and do not work

Hey @omar1,

Please share specific details and screenshots about your issue and steps to reproduce.

Thanks,
Tommy

HI,

I have the same challenge and have tried the guidance offered above … it still does not work.

Pls help

Hey @mthiga,

Double check you are using JWT App credentials.

You can also try regenerating your JWT Secret.

Let me know if that fixes the issue! :slight_smile:

Thanks,
Tommy

I am experiencing the same issue with the Moodle Zoom Meeting plugin. The plugin requires as shown on the screen captures provided above by other users the “Zoom API Key” and the “Zoom API secret”. When those settings are updated and saved on the plugin, it comes back with the message: “Connection status: Connection failed: Invalid access token.”
It seems that the connection with ZOOM can’t be established.
Please help.

I found the solution to the problem. This may help other users. The installation info for the plugin is on their github page and it reads:
Requires Zoom API key and secret. See https://marketplace.zoom.us/docs/guides/authorization/jwt/jwt-with-zoom. You will need to create a JWT app and that will generate the API key and secret.

You will need to have Zoom administrator access. Please note that the API key and secret is not the same as the LTI key/secret.

Here is the link to their github page: https://github.com/ucla/moodle-mod_zoom
It worked for me.

Hi @elearning1, glad that it works. Thanks for sharing!