URGENT: API token signature invalid

We’ve been using the moodle_mod-zoom plugin successfully for quite some time.

Suddenly this afternoon we’re getting the following error message:

Connection status: Connection failed: The Token’s Signature resulted invalid when verified using the Algorithm: HmacSHA256

There have been no code changes to the plugin on our end, which was functioning previously, so I am assuming this relates to the API or our account. While I have tried to pursue support through the account administrator, any advice would be appreciated. Thanks!

Hey @trevor_c,

Can you please reach out to the developers who created the Moodle app? Here is their support page:



Thanks @tommy. I meant to come back and post an update.

I think the problem was that we were still on the legacy api, and another staff member created a new JWT app, which ended up generating a new api secret. Once I updated the secret in Moodle, everything worked as expected again.

It was one of those days.

And just to clarify, it wasn’t the cosocloud LTI Moodle app. We don’t have any experience with that.

We are using the moodle_mod-zoom plugin from UCLA - https://github.com/ucla/moodle-mod_zoom

Thanks for following up!

Glad to see everything is working @trevor_c, please know that anyone with Zoom Developer write or Admin access can go in and reset that secret. Let us know if you need any further help!