Creating Meeting with API.. possible bugs

Hello

In the JSON that is posted to create the meeting, I have the following options included:

        'json' => [
          "topic" => "Test Meeting V33333333 ",
          "topic" => "Agenda for Meeting V222222222 ",
            "type" => 2,
            "alternative_hosts" => 'myemail@mydomain.com', //actual email used
            "host_video" => true,
            "join_before_host" => true,

Now… meeting created successfully, got the link.

When it was time for the meeting to start:
a. User A who didn’t sign into Zoom saw that host is yet to start the meeting
b. User B who had signed into zoom with her email address, saw the same thing
c. The alternative host specified above “myemail@mydomain.com” signed into zoom and saw the same message after being signed in. This user never got notified
d. The developer account with which the meeting was created just has one account in that organization… does that make a difference?

The docs don’t really call this out.

Is any of the above behaviour buggy?

Thanks

Hi @vnkmd
Thanks for reaching out to the Zoom Developer Forum, I am happy to help here!
Could you please make sure that you have this feature enabled in your account?

If you are the owner of the account or admin, please head to the Webportal, log in, and head to the Admin Tab.

In your Account setting, make sure to enable the Allow participants to join before host:

Let me know if this helps.
Elisa

Hi

Thanks for your reply… yes it had been enabled when I had tested.

Please see images below

Hey…it worked!

I think the settings take a few minutes to replicate or something… i don’t know…

But from my original post, one issue still remains: the “alternative_host”, which is a valid email address and has a zoom account, did not receive any notification.

The account with which the zoom meeting was created, did receive a notification, though.

Thanks

Hi @vnkmd
I’m happy to hear that worked!
Make sure that your alternative_hosts field is inside of your settings object, from the first post you made, I noticed you passed it outside of your settings object

Let me know if this helps,
Elisa