Delay in WebSocket connection

Hey @tommy and @vic.yang ,
Sometimes while joining Zoom Session, Zoom is taking way longer time to establish websocket connections.

Its gets stuck after:

ready to dec video!
ready to dec video!
ready to start!
ready to start!

Then after around 1min (sometimes even longer) It continues with:

JsAudioDec.js receive startMedia
JsAudioDec.js receive startMedia
Open_Audio_WebSocket_Connect
Open_Audio_WebSocket_Connect

Not sure if its something related but I found some websocket requests in network tab originating through Zoom like the ones below:

Which Web Video SDK version?
1.2.7

Can you let us know what could be the reason for such long delays in webscoket connections?

Hey @shoaib ,

Are you in debug mode? Are there issues with the SDK before those logs are printed?

Thanks,
Tommy

Hey @tommy ,

You mean browser debug mode? No.

No. No error or warning gets printed.

Additional Context:

Hey @shoaib ,

Interesting. Are there any issues with the Video SDK though? Does the video or audio not work?

I wonder if you are blocking some IPs that we use for the websockets: https://support.zoom.us/hc/en-us/articles/201362683-Zoom-network-firewall-or-proxy-server-settings

Thanks,
Tommy

Hey @tommy ,

Until websocket connection are not established, user can’t start video or audio It keeps saying something like:
on starting video: Camera is loading, Please wait.
on starting audio: Computer audio is loading, Please wait.

Once websocket connection are established, video and audio starts working.

Okay, will check once, But then It should get blocked every time right?

Hey @shoaib ,

After speaking to @vic.yang , we want to suggest upgrading to Video SDK 1.3.0 which includes an improvement around the data center selection logic. Helps reduce latency and improve in-meeting / session performance. Improvements include geo-fencing and greater prioritization of geographically-close servers.

Thanks,
Tommy

1 Like

Okay, Thanks @tommy ,
Will test in the updated version.

hey @tommy ,
We still observed this issue in the latest version as well (1.3.0).

Some Additional context:

  • Whenever this issue occurred it was observed that the user was joining the call for the first time.
  • After client.join()API is resolved we ask for audio video permission from user using:
    navigator.mediaDevices.getUserMedia({ audio: true, video: true })

In below screenshot, you can see the time these xhr requests takes sometimes for some reason.

Hey @shoaib

Do these assets deployed on your private server or using Zoom-served CDN?

Thanks
Vic

hey @vic.yang , Currently, we are using Zoom-served CDN.

Hey @shoaib

Could you open an individual tab to load the wasm file? We want to determine if this is an issue with our CDN network. Or a temporary workaround, serve these dependent assets on your own servers and specify the asset in the init method.

Thanks
Vic

hey @vic.yang ,
So, do you think serving these dependent assets from own servers will be faster than Zoom-served CDN?

Also just one more thing I forgot to mention that we are currently testing in our private environments with VPN turned on, not sure If this has something to do with it.

Hey @shoaib

We tested our CDN service, and it’s fine. Maybe this issue is related to your VPN network.

Thanks
Vic

hey @vic.yang ,
Okay, will test it without VPN as well.

But apart from this In general what do you recommend (or faster) to use for init method: Zoom-served CDN or serving from our own servers?

Hey @shoaib

It depends on you. Our default setting is using the Zoom-served CDN.

For the sake of some companies having their own assets access policies that prevent the use of external resources, we provide the option to use the privately served assets.

Thanks
Vic

Could you use https://www.speedtest.net/ test your speed? we want know your country. you can mask you ip hidden in the test result screenshot.
we test the source.zoom.us cdn latency can find the issue.
Thanks
Jack

hey @JackYang ,
Below are the speedtest results:

Country: India

Also, this speedtest was ran with VPN turned on.

hey @vic.yang and @JackYang ,

This I noticed while I was testing on Windows System (this happened only the first time I tried to join call):

Look at the time it took to download those files, and I was using the same internet as shown in the screenshot.

OS: Windows 10
Browser: Chrome (Version 103.0.5060.66 (Official Build) (64-bit))