DNS problem with Windows SDK

Hello!
We have a problem with starting zoom meetings on one of our devices. We made an application using the windows SDK. On one of our devices we can’t connect to a zoom meeting. We installed Fiddler to see what was wrong with the network connections and we saw that some zoom servers are not resolved by DNS servers.
We assumed the problem is with our network or ISP, but we tried to run desktop zoom client. Official zoom client worked perfectly. So, the main questionis: How this situation can be resolved? Why our app not working, but Zoom app is working? What else can we do to diagnose such problem? Thanks in advance.

Which Windows Meeting SDK version?
5.5.12511.422

Hey @atarkhanov,

Thanks for using the dev forum!

When you are unable to connect to a meeting, what SDKErrors are you given?

Thanks!
Michael

Hello, Michael!
Nice to meet you again :slight_smile:
We experienced problems 09/06/2021 and 09/07/2021. Then we set up a vpn to the problematic device and didn’t test it afterwards.
We didn’t see any errors. we caught meeting statuses only (these are our logs):
2021-09-06 10:58:30.189 +03:00 [INF] Status meeting: MEETING_STATUS_CONNECTING
2021-09-06 10:58:54.338 +03:00 [INF] Status meeting: MEETING_STATUS_DISCONNECTING
2021-09-06 10:58:54.339 +03:00 [INF] Status meeting: MEETING_STATUS_FAILED

or another logs:
2021-09-07 10:48:50.585 +03:00 [INF] Status meeting: MEETING_STATUS_CONNECTING
2021-09-07 10:49:16.918 +03:00 [INF] Status meeting: MEETING_STATUS_DISCONNECTING
2021-09-07 10:49:16.918 +03:00 [INF] Status meeting: MEETING_STATUS_FAILED
2021-09-07 10:49:18.944 +03:00 [INF] Status meeting: MEETING_STATUS_ENDED

Hey @atarkhanov,

Is this still happening, or did this only occur on those dates?

Thanks!
Michael

Hello, Michael!

Yes, it is happening now. Same as earlier: we can’t connect using SDK, but Zoom desktop client is connecting.