Download wasm files error, please check your network and firewall

Description
I am using zoom web sdk in my angular 8 application. And I have a pro account too. But the issue I am facing is, whenever I am trying to join a meeting, it shows “Download wasm files error, please check your network and firewall.”
I’ve used npm install for web sdk integration and all the wasm files are available at the location.

Error
The full error message or issue you are running into.

Which version?
zoomus/websdk@1.8.1

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. npm install @zoomus/websdk --save
  2. import { ZoomMtg } from ‘@zoomus/websdk’;
    ZoomMtg.preLoadWasm();
    ZoomMtg.prepareJssdk();
  3. Generating signature using:
    this.signature = ZoomMtg.generateSignature({
    meetingNumber: this.meetConfig.meetingNumber,
    apiKey: this.meetConfig.apiKey,
    apiSecret: this.meetConfig.apiSecret,
    role: this.meetConfig.role,
    success: function(res){
    console.log(‘result’,res.result);
    },
    error: (res) => {
    console.log(‘error’, res);
    }
    });
  4. Joining meeting using:
    leaveUrl: ‘https://phyziohealth.com:9002’,
    isSupportAV: true,
    success: (res) => {
    ZoomMtg.join({
    meetingNumber: this.meetConfig.meetingNumber,
    userName: this.meetConfig.userName,
    signature: this.signature,
    apiKey: this.meetConfig.apiKey,
    userEmail: ‘xyz@gmail.com’,
    passWord: this.meetConfig.passWord,
    success: (res) => {
    console.log(‘join meeting success’);
    },
    error: (res) => {
    console.log(‘response’, res);
    }
    });
    },
    error: (res) => {
    console.log(‘erroe’, res);
    }
    });
  5. Error - “Download wasm files error, please check your network and firewall.”

Screenshots
Screenshot 2020-10-01 174032

Hey @phyziohealth,

Are you on a VPN or under a firewall? Sometimes this will cause the files to be inaccessible.

Thanks,
Tommy

Hey @tommy,

No VPN and no firewall. The server is hosted on digitalocean and using nginx and pm2 for running the app.
Adding the screenshot to confirm that no VPN and firewall is added on the droplet.

@phyziohealth Hi, I wanted to follow up on this.

Were you previously experiencing this or did you start experiencing this around October 2nd? If yes, we were experiencing issues with our WebSDK. The issues however have been resolved since.

Are you still experiencing these issues?

Hi @Ojus, we just integrated this into our site and facing issues with the latest version of zoom web sdk.

Hi,

Can you please send the following information at developersupport@zoom.us?

1] Meeting IDs that you experienced issues with
2] Your Signature
3] Steps to reproduce the issues

Thanks

@Ojus information sent. Please check and respond. Thanks

1 Like

Thanks for sending that info to us! :slight_smile:

-Tommy

Hi @Ojus, how much time will it take? We are stuck.

Hey @phyziohealth,

What is your ticket number? Happy to look into the status of it.

Thanks,
Tommy

The ticket number is 8095526

Thanks @phyziohealth!

We see that if it takes more than 30 seconds to load the Web SDK files we throw that error. We are considering extending the timeout time which should fix your issue. (CS-2379)

Thanks,
Tommy

Hi @tommy,

When will it happen? The extend in timeout?

Hey @phyziohealth,

Once I have a timeline for you, I will let you know. :slight_smile:

Thanks,
Tommy

Hey @phyziohealth,

This will be included in version 1.8.5.

Thanks,
Tommy

I think everyone is facing this issue. Can you pls resolve this in priority?

@phyziohealth

I think your problem is completely different than what was indicated here.
You’re getting a timeout because you did not configure the WASM file location properly.
The javascript, wasm files required by the SDK to execute are not available from your web site.

You are trying to use the local mode, not the CDN zoom resources. Which means you have to make your local static resources available from your web site so that your users can download it.

Have a look again at the documentation on the NPM package:

Either:

  • call the setZoomJSLib with zoom CDN url as first parameter and ‘/av’ as second
  • or setup a path where your local wasm, js, mp3 zoom static resources are available on your installation location.

For the second option (that you’re using obviously), depending on where and how you host / deploy your application, just doing an npm install is not enough.

Hey @premium, @phyziohealth,

The download wasm files error will be fixed later this month in version 1.8.2.

Thanks for your input as well @nvivot!

Thanks,
Tommy

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.