Enable meeting:read:admin permission

Enable access to meeting:read:admin for a Server-to-Server app

My Zoom admin cannot find a way to add permissions as they are displayed in the API documentation (for example: meeting:read:admin). He has been setting permissions by going to ADMIN > User Management > Roles > App Developer and checking boxes on the listed fields. There is not ‘Meetings’ section on this screen.

Is there somewhere my admin can go to set permissions for the app and/or my account in the format meeting:read:admin?

We’re still looking for help with this. How can admins add/remove scopes in the format meeting:read:admin?

Hi @josh.mcelfresh , the scope doesn’t look like that in the UI, but selecting the check boxes for the permissions applies the scope. For instance, depending on your account config, it may look something like this:

control+F for meetings in that section to select the permissions. Make sure the appropriate app-type permissions are selected as well.

The Meetings checkbox in your screenshot is from the Dashboards sections of the admin control panel.

That checkbox enables dashboard permissions. When I scroll to the bottom of the scopes list I still don’t see meetings permissions, only dashboard permissions.

When I make a call to https://api.zoom.us/v2/users/${userId}/meetings I get back:

Request failed with status code 400 {
  code: 4711,
  message: 'Invalid access token, does not contain scopes:[meeting:read:list_meetings, meeting:read:list_meetings:admin].'

Hi @josh.mcelfresh , is the user edit permissions enabled for the admin?

Please see below guidance: