Err_cert_common_name_invalid

I use Web SDK 1.7.8 in HTTPS environment and when entering a meeting the console shows several errors of SSL certificates in zoom sub domains. This causes errors in our system. When trying to access the domains directly through the browser, it accuses ssl certificate error.
The domains are:

jquery-3.5.1.min.js:2 GET https://nyrwc.zoom.us/wc/ping/6301164998?ts=1591227130275&auth=G-zM2OiU0BSh…rwcToken=NjYMrR91o6vRpxRI6hddXlzpm0_0CvUS566752kKgiM&dmz=1&_=1591227126006 net::ERR_CERT_COMMON_NAME_INVALID

jquery-3.5.1.min.js:2 GET https://rwcdv.zoom.us/wc/ping/6301164998?ts=1591227130275&auth=G-zM2OiU0BSh…rwcToken=7_wHpLZvF9IDrtPawKPTFamGx4OatVl4JnsPxNLX01U&dmz=1&_=1591227126008 net::ERR_CERT_COMMON_NAME_INVALID

jquery-3.5.1.min.js:2 GET https://scrwc.zoom.us/wc/ping/6301164998?ts=1591227130275&auth=G-zM2OiU0BSh…rwcToken=X3IV4ag9outxXmuTQgb5jTSM0XjUVXoxjFuPvLccfKw&dmz=1&_=1591227126019 net::ERR_CERT_COMMON_NAME_INVALID

jquery-3.5.1.min.js:2 GET https://rwcprod.zoom.us/wc/ping/6301164998?ts=1591227130275&auth=G-zM2OiU0B…rwcToken=5dTl70GiZBZf_NrrwVj7dVKmPMGT-6HLyYPLia-Gewg&dmz=1&_=1591227126007 net::ERR_CERT_COMMON_NAME_INVALID

jquery-3.5.1.min.js:2 GET https://rwcam.zoom.us/wc/ping/6301164998?ts=1591227130275&auth=G-zM2OiU0BSh…rwcToken=-DefiiDvwlShoceaaPLi6Q4-K8tkPZCWcZXDfjVD5I4&dmz=1&_=1591227126012 net::ERR_CERT_COMMON_NAME_INVALID

zoomus-websdk.umd.min.js:2 >>>>>>>> CREATE JSMEDIASKD INSTANCE <<<<<<<<

jquery-3.5.1.min.js:2 GET https://rwchk.zoom.us/wc/ping/6301164998?ts=1591227130275&auth=G-zM2OiU0BSh…rwcToken=8VpDEeLdnfwvXw4ADqKA3phZ_AOVY_cIXVQ9_ibR5dk&dmz=1&_=1591227126014 net::ERR_CERT_COMMON_NAME_INVALID

jquery-3.5.1.min.js:2 GET https://rwchy.zoom.us/wc/ping/6301164998?ts=1591227130275&auth=G-zM2OiU0BSh…rwcToken=XQLzYqIIstoRl4Z43thYMuOv6R0GgyYZ92hWTecajvM&dmz=1&_=1591227126009 net::ERR_CERT_COMMON_NAME_INVALID

jquery-3.5.1.min.js:2 GET https://rwcsy.zoom.us/wc/ping/6301164998?ts=1591227130275&auth=G-zM2OiU0BSh…rwcToken=qDjj35ze0TrTA3CCkw4C6GL5yJ6iZOuTVk4jAF6mmBo&dmz=1&_=1591227126013 net::ERR_CERT_COMMON_NAME_INVALID

I noticed the same thing and it didn’t seem to affect functionality at all on my end.

But other people on my remote team started reporting video or audio cutting out. Could that be related? Seeing “/ping/” in the endpoint makes it look like the player is checking the connection to potential datacenters. So if these are all timing out, maybe people are getting routed to suboptimal datacenters?

I am facing same error , also its not allowing to connect to meeting
i am using 1.7.8 CDN Web

We are seeing this as well, although it’s inconsistant. Sometimes it looks like resources are loaded from URLs that DO have valid certs, but many times it’s attempting to load from servers with invalid certificates.

It’s happening in 1.7.8, but frequently occurs in 1.7.7 as well.

Hi @adrianogaspar @odrilon @ashisharora119 @jmauck

Thanks for reporting the issue. Our backed Engineers are working to resolve this issue quickly. We’ll update this thread as soon as we fix the bug.

Thanks

1 Like

@Michael_Purnell
Did you get chance to fix it ?

Hey @ashisharora119,

It should be fixed now. Please test and let us know if you run into any issues. :slight_smile:

Thanks,
Tommy

please su ayuda

Hey @miguel.mmmk,

Please upgrade to Web SDK version 1.7.8.

Thanks,
Tommy

I ran into the same issue which ashisharora119 faced with websdk v 1.7.9.
It happens when i quit a meeting and then immediately join another. But it works fine after some delay (usually 10 minutes) after the meeting ends. Am using pro key.

ZoomMtg.setZoomJSLib(‘https://source.zoom.us/1.7.9/lib’, ‘/av’);

Should I try the china sdk link? and this error does not happen in local, but in secure sites(https)

Hey @prasanna8,

Strange, it should work right away. What locale are you in?

Thanks,
Tommy

India. Which cdn link is preferred for India ?
And this error happens also in non secure sites as well.
Update: Sometime even the err cert common name invalid doesn’t even occur. But I’m getting the same issue.

Tried with both sdk v 1.7.8 and 1.7.9.

Error in the console. which are same as jmauck 's.
Screenshot 2020-08-04 at 10.26.29

No errors in console, but still occurs
Screenshot 2020-08-04 at 00.36.12

Hey @prasanna8,

Can you try upgrading to version 1.7.10. This is most likely a caching issue.

In India, either the Local method or CDN Global is best.

-Tommy

1 Like

same issue on 1.7.10.

When I just try to go to the host, I get the following error in curl:

curl -v rwcprod.zoom.us

  • TCP_NODELAY set

  • Connected to YOUR HOST (192.204.15.102) port 443 (#0)

  • ALPN, offering h2

  • ALPN, offering http/1.1

  • successfully set certificate verify locations:

  • TLSv1.3 (OUT), TLS handshake, Client hello (1):

  • TLSv1.3 (IN), TLS handshake, Server hello (2):

  • TLSv1.2 (IN), TLS handshake, Certificate (11):

  • TLSv1.2 (IN), TLS handshake, Server key exchange (12):

  • TLSv1.2 (IN), TLS handshake, Server finished (14):

  • TLSv1.2 (OUT), TLS handshake, Client key exchange (16):

  • TLSv1.2 (OUT), TLS change cipher, Client hello (1):

  • TLSv1.2 (OUT), TLS handshake, Finished (20):

  • TLSv1.2 (IN), TLS handshake, Finished (20):

  • SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384

  • ALPN, server did not agree to a protocol

  • Server certificate:

  • subject: C=US; ST=California; L=San Jose; O=Zoom Video Communications, Inc.; CN=*.ny.zoom.us

  • start date: May 11 00:00:00 2020 GMT

  • expire date: May 16 12:00:00 2022 GMT

  • subjectAltName does not match rwcprod.zoom.us

  • SSL: no alternative certificate subject name matches target host name ‘YOUR HOST’

  • stopped the pause stream!

  • Closing connection 0

  • TLSv1.2 (OUT), TLS alert, Client hello (1):
    curl: (51) SSL: no alternative certificate subject name matches target host name YOUR HOST’

Sorry for the above message having YOUR HOST in it, but I could not post the domain name more than twice in the message. :slightly_smiling_face:

In looking at the site’s cert, it is appears to be valid for *.sc.zoom.us, and does not have alternative DNS names entries.

Caveat: I am by no means claiming to be an expert, but have seen this in my own work previously, and hoping it helps.

Hey @mbwhipple,

To confirm, you are also seeing this error when using the Web SDK version 1.7.10? Can you share steps to reproduce and a screenshot of the error?

Thanks,
Tommy

Hello Tommy,

Yes I was seeing the same error. After a few hours delay, everything started working, and I do not know why. I am able to continue with no issues currently. Still, I see the issues with the web site, but all is good with the api.

Thanks for the rapid response. You guys have a great product.

Mark

1 Like

Hey @mbwhipple,

Thanks for the compliment! :slight_smile: I am happy to hear the error went away.

Please let us know if you run into any other issues.

-Tommy