Error code 200 when I try to get polls results

API Endpoint(s) and/or Zoom API Event(s)

I’m trying to fetch the polls results but I’m receiving the following error. I already have developer access and the meeting:read:admin permission.

{'response': {'status_code': 400, 'content_size': 2, 'content': {'code': 200, 'message': 'No permission.'}}}

Can you please help me on that? The meeting UUID is JFossQQgRdmFGkIWVrMJSQ==

Welcome, @amanda.fagundes,

Thank you for posting in the forum. You are getting that error because you do not have the appropriate permission to hit that endpoint. You can verify you have the appropriate permission via the access token response. There should be a scope property you can validate against:

    "access_token": " YOUR ACCESS TOKEN",
    "token_type": "bearer",
    "expires_in": 3599,
    "scope": "user:write:admin meeting_token:read:admin:local_recording user:read:admin contact_center_report:read:admin recording:write:admin dashboard_webinars:read:admin contact_center_contact:read:admin meeting:read:admin recording:read:admin meeting:write:admin"

Either reach out to your account admin to request the appropriate permission or change the permission accordingly, if you are able:

List past meeting’s poll results

Enabling polling for meetings

Hey @donte.zoom, thank you for the answer.

How can I get this permission? I can access the scope settings, but I’m not finding this option. What exactly do I need to ask the account admin?

@amanda.fagundes ,

Can you share a screenshot of the scope you are seeing?

OAuth Scopes

Also, can you confirm which Zoom Marketplace App type you are using?

Understanding app types

That aside, here is our support documentation on How to change permissions for a role

Using role management

Privileges and Role Management

Zoom For Developer Web Portal Link

I’m receiving this error message when I try to attach an image here: "An error occurred: Sorry, you can't embed media items in a post."

But I created a Server-To-Server OAuth, and I’m trying to change the scopes on this URL:

And I have all these privileges in the advanced features

Any updates on this issue?

Thank you for your response. I’ll look into why I’m you are unable post image.

That aside, here’s out help documentation on enabling sever - to- server app permissions.

Let me know if this helps.