Having issue with meetings API

I keep getting a 400 error with the response below when I call this endpoint - https://api.zoom.us/v2/past_meetings/{meeting_id}/polls
“code”: 200,
“message”: “No permission.”

All the permissions have been given

On the admin panel I can see meeting:read:meeting:admin but this meeting:read:admin,meeting:read is what the API doc mentioned. They look the same to me. I added it but I’m still getting the same error.

I need help

Hi @ayotomiwa . the scopes listed on the current endpoint documentation are the legacy scopes.

meeting:read:admin,meeting:read are two separate legacy scopes: meeting:read:admin and meeting:read

I do not see this endpoint listed as having available granular scopes at the time of writing which may be the cause of your issue.

Are you able to apply the scopes for the endpoints listed here and query them successfully?

I’m trying to get poll results in meetings. I newly tried this endpoint from the list above.

The two scopes that was listed do not exist as available scopes in on the Zoom OAuth apps

@ayotomiwa to confirm, with the following endpoint you tried to add report:read:list_meeting_polls:admin but did not see it?

Are the appropriate Reports settings/permissions enabled for your role type? Check for survey and poll management as well please.

See example:

It worked. All good now

Thanks for confirming @ayotomiwa