Error updating to version 1.9.0

Dear today, I tried to join a zoom meeting through the WebSDK, throwing the following error:


1

Upgrade to version 1.9.0 but it keeps throwing the same error, I already delete the .dist folder and delete the node_modules to install all the packages again, but I can’t.

Are there any considerations to take into account?

Until January 13 I was able to work properly with version 1.8.6, this day was the last test we did.

I really appreciate your help as we are about to go into production.

Hey @supercuidadores,

Thank you for reaching out to the Zoom Developer Forum. Are you using setZoomJSLib() in your code? If so, make sure that the library you are using has an up-to-date version as well.

If that doesn’t help, are you able to share a public git repo containing your code?

Thanks,
Max

At the moment what I can tell you is that I kept trying and the error comes out when I send the value 0 in role, when I send the value 1 if the meeting opens, currently in my system role 1 is for tutors and 0 for students , the tutor manages to connect but the students get that error

I found this link referring to my same error but in another version

This is the link of repository

Thanks so much for the help

Hey @supercuidadores,

Thank you for providing additional information.

That’s a good find! Do the meetings you are attempting to join have registration required? This currently is not supported by the Web SDK, although the messaging should be updated.

Thank you for providing that! I’m not seeing anything that would cause this based on what you have setup there.

One thing I did see is that you pushed your Api Key and Secret to the public git repository. This presents a security issue. In order to prevent others from accessing your account, you’ll want to delete the git repository so that the git history is removed, then regenerate your key and secret.

With that being said, best practice is to use environment variables to set and get your API key and secret. In this fashion, you can set the credentials in your environment and they aren’t pushed to the git repo.

Thanks,
Max